In article <[EMAIL PROTECTED]>,
Alex Martelli <[EMAIL PROTECTED]> wrote:
>
>list(iterimage(etc etc))
>
>is surely a better way to express identical semantics.  More generally,
>[x for x in whatever] (whether x is a single name or gets peculiarly
>unpacked and repacked like here) is a good example of inappropriate LC,
>to get back to the question in the subject: list(whatever) is the "one
>obvious way" to perform the same task.

Except of course, when it's

[x for x in whatever if x]

I'm exceedingly fond of replacing filter() with listcomps.  They're so
much more readable and often faster.
-- 
Aahz ([EMAIL PROTECTED])           <*>         http://www.pythoncraft.com/

"Typing is cheap.  Thinking is expensive."  --Roy Smith
-- 
http://mail.python.org/mailman/listinfo/python-list

Reply via email to