Wouldn't this be nicer, though?:

def getChildLogger(id):
    return logger.getChild(id)

def someFunc():
    logger = getChildLogger("someFunc")


-- UNTESTED --

No messing around with globals this way, and it's more extendable. And
'globals()["logger"].getChild("someFunc")' reads like a brick.
-- 
http://mail.python.org/mailman/listinfo/python-list

Reply via email to