On Sun, 26 Jun 2005 03:36:58 -0400, Chinook <[EMAIL PROTECTED]> wrote: ... > Here is something I copied from somewhere (someone else might know the > source): > > Summary of Naming Conventions ... > > Hope it does not come out too jumbled,
It did, but it seemed so useful that I repost it with minor changes and proper formatting: Summary of Naming Conventions Type Convention Example ----------------------------------------------------------------------------- function action_with_underscores find_all variable noun_with_underscores curr_index constant NOUN_ALL_CAPS ALLOWED_RNA_PAIRS class MixedCaseNoun RnaSequence public property MixedCaseNoun IsPaired private property _noun_with_leading_underscore _is_updated public method mixedCaseExceptFirstWordVerb stripDegenerate private method _verb_with_leading_underscore _check_if_paired really private data __two_leading_underscores __delegator_object_ref parameters matching property SameAsProperty __init__(data, Alphabet=None) factory function MixedCase InverseDict module lowercase_with_underscores unit_test ----------------------------------------------------------------------------- Note that calling 'IsPaired' and '_is_updated' a noun is clearly wrong. There are probably other problems with it, too. /Jorgen -- // Jorgen Grahn <jgrahn@ Ph'nglui mglw'nafh Cthulhu \X/ algonet.se> R'lyeh wgah'nagl fhtagn! -- http://mail.python.org/mailman/listinfo/python-list