Currently the common pattern for yielding the elements in a sequence is as 
follows:

   for x in sequence: yield x

I propose the following replacement (the result would be identical):

   yield *sequence

imho the current syntax is much more intuitive, it is obvious to infer what it 
does
by looking at it. I favor a more intuitive syntax over a more concise one.


Regards,
Alan Evangelista
--
https://mail.python.org/mailman/listinfo/python-list

Reply via email to