On Fri, Nov 10, 2017 at 7:16 AM, Kirill Balunov <kirillbalu...@gmail.com> wrote:
> What is the future of the PEP 467 ("Minor API improvements for binary
> sequences")? It was not accepted and was not rejected, although there was a
> rather active discussion.

I don't know. This is probably a question for python-dev.

> In addition to what is stated in the PEP, I would like to know your opinion
> on the additional issue:
> At present, the repr() and str() of bytes return the same thing - which
> looks  more as "binary string". May be it is better if the repr() will
> return "binary sequence" -> only escaped hex values.

Why would this be better? For bytes objects that are based on ASCII or
UTF-8 strings it will make them harder to read. For users who might be
using the repr() to serialize the bytes object, it will make the
serialization larger. Also, the str() of a container like a list uses
the repr() of its contents, so while readability is not the main goal
of a repr() it is still a good thing to have.
-- 
https://mail.python.org/mailman/listinfo/python-list

Reply via email to