Source: pyqt5
Version: 5.7+dfsg-5
Severity: serious
Tags: buster sid
User: debian...@lists.debian.org
Usertags: qa-ftbfs-20170805 qa-ftbfs
Justification: FTBFS on amd64

Hi,

During a rebuild of all packages in sid, your package failed to build on
amd64.

Relevant part (hopefully):
> +------------------------------------------------------------------------------+
> | Install package build dependencies                                          
>  |
> +------------------------------------------------------------------------------+
> 
> 
> Setup apt archive
> -----------------
> 
> Merged Build-Depends: debhelper (>= 9), dh-python, dpkg-dev (>= 1.16.1~), 
> libdbus-1-dev (>= 1.0.2), libglib2.0-dev, libicu-dev, libpulse-dev, 
> libqt5opengl5-dev (>= 5.7.0), libqt5sensors5-dev (>= 5.7.0), 
> libqt5serialport5-dev (>= 5.7.0), libqt5svg5-dev (>= 5.7.0), 
> libqt5webchannel5-dev (>= 5.7.1), libqt5webkit5-dev (>= 5.7.0), 
> libqt5websockets5-dev (>= 5.7.0), libqt5x11extras5-dev (>= 5.7.0), 
> libqt5xmlpatterns5-dev (>= 5.7.0), libsqlite3-dev, libudev-dev, libxml2-dev, 
> libxslt1-dev, python-all-dbg, python-all-dev (>= 2.6.6-3~), python-dbus, 
> python-dbus-dbg, python-dbus-dev, python-sip-dbg, python-sip-dev (>= 4.18), 
> python3-all-dbg, python3-all-dev (>= 3.3.2-5~), python3-dbus, 
> python3-dbus-dbg, python3-sip-dbg, python3-sip-dev (>= 4.18), 
> qtdeclarative5-dev (>= 5.7.0), qtlocation5-dev (>= 5.7.0), qtmultimedia5-dev 
> (>= 5.7.0), qtpositioning5-dev (>= 5.7.0), qttools5-dev (>= 5.7.0), 
> qtwebengine5-dev (>= 5.7.1+dfsg-3~), fdupes, python3-sphinx (>= 1.3)
> Filtered Build-Depends: debhelper (>= 9), dh-python, dpkg-dev (>= 1.16.1~), 
> libdbus-1-dev (>= 1.0.2), libglib2.0-dev, libicu-dev, libpulse-dev, 
> libqt5opengl5-dev (>= 5.7.0), libqt5sensors5-dev (>= 5.7.0), 
> libqt5serialport5-dev (>= 5.7.0), libqt5svg5-dev (>= 5.7.0), 
> libqt5webchannel5-dev (>= 5.7.1), libqt5webkit5-dev (>= 5.7.0), 
> libqt5websockets5-dev (>= 5.7.0), libqt5x11extras5-dev (>= 5.7.0), 
> libqt5xmlpatterns5-dev (>= 5.7.0), libsqlite3-dev, libudev-dev, libxml2-dev, 
> libxslt1-dev, python-all-dbg, python-all-dev (>= 2.6.6-3~), python-dbus, 
> python-dbus-dbg, python-dbus-dev, python-sip-dbg, python-sip-dev (>= 4.18), 
> python3-all-dbg, python3-all-dev (>= 3.3.2-5~), python3-dbus, 
> python3-dbus-dbg, python3-sip-dbg, python3-sip-dev (>= 4.18), 
> qtdeclarative5-dev (>= 5.7.0), qtlocation5-dev (>= 5.7.0), qtmultimedia5-dev 
> (>= 5.7.0), qtpositioning5-dev (>= 5.7.0), qttools5-dev (>= 5.7.0), 
> qtwebengine5-dev (>= 5.7.1+dfsg-3~), fdupes, python3-sphinx (>= 1.3)
> dpkg-deb: building package 'sbuild-build-depends-pyqt5-dummy' in 
> '/<<BUILDDIR>>/resolver-01Uh6s/apt_archive/sbuild-build-depends-pyqt5-dummy.deb'.
> dpkg-scanpackages: warning: Packages in archive but missing from override 
> file:
> dpkg-scanpackages: warning:   sbuild-build-depends-core-dummy 
> sbuild-build-depends-pyqt5-dummy
> dpkg-scanpackages: info: Wrote 2 entries to output Packages file.
> Ign:1 copy:/<<BUILDDIR>>/resolver-01Uh6s/apt_archive ./ InRelease
> Get:2 copy:/<<BUILDDIR>>/resolver-01Uh6s/apt_archive ./ Release [963 B]
> Ign:3 copy:/<<BUILDDIR>>/resolver-01Uh6s/apt_archive ./ Release.gpg
> Get:4 copy:/<<BUILDDIR>>/resolver-01Uh6s/apt_archive ./ Sources [815 B]
> Get:5 copy:/<<BUILDDIR>>/resolver-01Uh6s/apt_archive ./ Packages [866 B]
> Fetched 2644 B in 0s (0 B/s)
> Reading package lists...
> Reading package lists...
> 
> Install pyqt5 build dependencies (apt-based resolver)
> -----------------------------------------------------
> 
> Installing build dependencies
> Reading package lists...
> Building dependency tree...
> Reading state information...
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
> 
> The following packages have unmet dependencies:
>  sbuild-build-depends-pyqt5-dummy : Depends: qtwebengine5-dev (>= 
> 5.7.1+dfsg-3~) but it is not going to be installed
> E: Unable to correct problems, you have held broken packages.
> apt-get failed.

The full build log is available from:
   http://aws-logs.debian.net/2017/08/05/pyqt5_5.7+dfsg-5_unstable.log

A list of current common problems and possible solutions is available at
http://wiki.debian.org/qa.debian.org/FTBFS . You're welcome to contribute!

About the archive rebuild: The rebuild was done on EC2 VM instances from
Amazon Web Services, using a clean, minimal and up-to-date chroot. Every
failed build was retried once to eliminate random failures.

_______________________________________________
Python-modules-team mailing list
Python-modules-team@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/python-modules-team

Reply via email to