Package: python-pymodbus-doc
Version: 1.4.0+dfsg-1
Severity: serious
Usertags: piuparts


during a test with piuparts I noticed your package fails to upgrade from
It installed fine in 'stable', then the upgrade to 'sid' fails
because it tries to overwrite other packages files without declaring a
Breaks+Replaces relation.

See policy 7.6 at

This test intentionally skipped 'testing' to find file overwrite
problems before packages migrate from 'unstable' to 'testing'.

>From the attached log (scroll to the bottom...):

  Selecting previously unselected package python-pymodbus-doc.
  Preparing to unpack .../6-python-pymodbus-doc_1.4.0+dfsg-1_all.deb ...
  Unpacking python-pymodbus-doc (1.4.0+dfsg-1) ...
  dpkg: error processing archive 
   trying to overwrite 
'/usr/share/doc/python-pymodbus/examples/common/README.rst', which is also in 
package python-pymodbus 1.2.0+git20151013-1
  dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
  Errors were encountered while processing:



Attachment: python-pymodbus=1.2.0+git20151013-1_python-pymodbus-doc=1.4.0+dfsg-1.log.gz
Description: application/gzip

Python-modules-team mailing list

Reply via email to