Xqt has submitted this change and it was merged. ( 
https://gerrit.wikimedia.org/r/403404 )

Change subject: [doc] Show currently supported python versions
......................................................................


[doc] Show currently supported python versions

Change-Id: Ic93bb50a4d48a6831c31ef9a3d1823855cc1284f
---
M pwb.py
M setup.py
2 files changed, 10 insertions(+), 10 deletions(-)

Approvals:
  Dvorapa: Looks good to me, but someone else must approve
  Dalba: Looks good to me, approved
  jenkins-bot: Verified



diff --git a/pwb.py b/pwb.py
index f4ff16d..2340367 100755
--- a/pwb.py
+++ b/pwb.py
@@ -9,7 +9,7 @@
 and it will use the package directory to store all user files, will fix up
 search paths so the package does not need to be installed, etc.
 """
-# (C) Pywikibot team, 2015-2016
+# (C) Pywikibot team, 2015-2018
 #
 # Distributed under the terms of the MIT license.
 #
@@ -33,10 +33,10 @@
 PY26 = (PYTHON_VERSION < (2, 7))
 
 versions_required_message = """
-Pywikibot not available on:
-%s
+Pywikibot is not available on:
+{version}
 
-Pywikibot is only supported under Python 2.6.5+, 2.7.2+ or 3.3+
+This version of Pywikibot only supports Python 2.6.5+, 2.7.2+ or 3.3+.
 """
 
 
@@ -49,7 +49,7 @@
 
 
 if not python_is_supported():
-    print(versions_required_message % sys.version)
+    print(versions_required_message.format(version=sys.version))
     sys.exit(1)
 
 pwb = None
diff --git a/setup.py b/setup.py
index 495d3f2..284bb80 100644
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,7 @@
 # -*- coding: utf-8 -*-
 """Installer script for Pywikibot 3.0 framework."""
 #
-# (C) Pywikibot team, 2009-2017
+# (C) Pywikibot team, 2009-2018
 #
 # Distributed under the terms of the MIT license.
 #
@@ -26,10 +26,10 @@
 PY26 = (PYTHON_VERSION < (2, 7))
 
 versions_required_message = """
-Pywikibot not available on:
-%s
+Pywikibot is not available on:
+{version}
 
-Pywikibot is only supported under Python 2.6.5+, 2.7.2+ or 3.3+
+This version of Pywikibot only supports Python 2.6.5+, 2.7.2+ or 3.3+.
 """
 
 
@@ -42,7 +42,7 @@
 
 
 if not python_is_supported():
-    raise RuntimeError(versions_required_message % sys.version)
+    raise RuntimeError(versions_required_message.format(version=sys.version))
 
 test_deps = ['bz2file', 'mock']
 

-- 
To view, visit https://gerrit.wikimedia.org/r/403404
To unsubscribe, visit https://gerrit.wikimedia.org/r/settings

Gerrit-MessageType: merged
Gerrit-Change-Id: Ic93bb50a4d48a6831c31ef9a3d1823855cc1284f
Gerrit-PatchSet: 8
Gerrit-Project: pywikibot/core
Gerrit-Branch: master
Gerrit-Owner: Xqt <i...@gno.de>
Gerrit-Reviewer: Dalba <dalba.w...@gmail.com>
Gerrit-Reviewer: Dvorapa <dvor...@seznam.cz>
Gerrit-Reviewer: John Vandenberg <jay...@gmail.com>
Gerrit-Reviewer: Lokal Profil <lokal.pro...@gmail.com>
Gerrit-Reviewer: Xqt <i...@gno.de>
Gerrit-Reviewer: Zoranzoki21 <zorandori4...@gmail.com>
Gerrit-Reviewer: jenkins-bot <>

_______________________________________________
Pywikibot-commits mailing list
Pywikibot-commits@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/pywikibot-commits

Reply via email to