jenkins-bot has submitted this change. ( 
https://gerrit.wikimedia.org/r/c/pywikibot/core/+/1329167?usp=email )

Change subject: welcome: Reuse lowercased username
......................................................................

welcome: Reuse lowercased username

Lowercase each username once before applying whitelist and blacklist
filters. Reusing the normalized value avoids repeating the same conversion
for every filter entry without changing matching behavior.

Change-Id: Ibd4b917e2e8c4f60c7038cfa1f3ce799ecc31a12
---
M scripts/welcome.py
1 file changed, 8 insertions(+), 5 deletions(-)

Approvals:
  jenkins-bot: Verified
  Xqt: Looks good to me, approved




diff --git a/scripts/welcome.py b/scripts/welcome.py
index b2b54c7..057ddef 100755
--- a/scripts/welcome.py
+++ b/scripts/welcome.py
@@ -548,7 +548,7 @@
             self.define_sign()
         get_welcome_text(self.site)  # check whether the script is localized

-    def bad_name_filer(self, name, force: bool = False) -> bool:
+    def bad_name_filer(self, name: str, force: bool = False) -> bool:
         """Check for bad names."""
         if not globalvar.filt_bad_name:
             return False
@@ -627,14 +627,17 @@
             self._whitelist = list_white + whitelist_default

         with suppress(UnicodeEncodeError):
+            lower_name = name.lower()
             for wname in self._whitelist:
-                if wname.lower() in str(name).lower():
-                    name = name.lower().replace(wname.lower(), '')
+                lower_wname = wname.lower()
+                if lower_wname in lower_name:
+                    lower_name = lower_name.replace(lower_wname, '')
+                    name = lower_name
                     for bname in self._blacklist:
                         self.bname[name] = bname
-                        return bname.lower() in name.lower()
+                        return bname.lower() in lower_name
             for bname in self._blacklist:
-                if bname.lower() in str(name).lower():  # bad name positive
+                if bname.lower() in lower_name:  # bad name positive
                     self.bname[name] = bname
                     return True
         return False

--
To view, visit 
https://gerrit.wikimedia.org/r/c/pywikibot/core/+/1329167?usp=email
To unsubscribe, or for help writing mail filters, visit 
https://gerrit.wikimedia.org/r/settings?usp=email

Gerrit-MessageType: merged
Gerrit-Project: pywikibot/core
Gerrit-Branch: master
Gerrit-Change-Id: Ibd4b917e2e8c4f60c7038cfa1f3ce799ecc31a12
Gerrit-Change-Number: 1329167
Gerrit-PatchSet: 3
Gerrit-Owner: Mahveotm <[email protected]>
Gerrit-Reviewer: Xqt <[email protected]>
Gerrit-Reviewer: jenkins-bot
_______________________________________________
Pywikibot-commits mailing list -- [email protected]
To unsubscribe send an email to [email protected]

Reply via email to