Eric Blake <ebl...@redhat.com> writes:
> These days, many programs are including a bug-reporting address,
> or better yet, a link to the project web site, at the tail of
> their --help output. However, we were not very consistent at
> doing so: only qemu-nbd and qemu-qa mentioned anything, with the
> latter pointing to an individual person instead of the project.
> Add a new #define that sets up a uniform string, mentioning both
> bug reporting instructions and overall project details, and which
> a downstream vendor could tweak if they want bugs to go to a
> downstream database. Then use it in all of our binaries which
> have --help output.
> The canned text intentionally references http:// instead of https://
> because our https website currently causes certificate errors in
> some browsers. That can be tweaked later once we have resolved the
> web site issued.
> Signed-off-by: Eric Blake <ebl...@redhat.com>
> include/qemu-common.h | 5 +++++
> vl.c | 4 +++-
> bsd-user/main.c | 2 ++
> linux-user/main.c | 4 +++-
> qemu-img.c | 2 +-
> qemu-io.c | 5 +++--
> qemu-nbd.c | 2 +-
> qga/main.c | 2 +-
> 8 files changed, 19 insertions(+), 7 deletions(-)
> diff --git a/include/qemu-common.h b/include/qemu-common.h
> index b5adbfa5e9..e751361458 100644
> --- a/include/qemu-common.h
> +++ b/include/qemu-common.h
> @@ -22,6 +22,11 @@
> #define QEMU_COPYRIGHT "Copyright (c) 2003-2017 " \
> "Fabrice Bellard and the QEMU Project developers"
> +/* Bug reporting information for --help arguments, About dialogs, etc */
> +#define QEMU_BUGREPORTS \
> + "See <http://qemu.org/contribute/report-a-bug> for bug reports.\n" \
"See ... for bug reports" sounds like it's about browsing existing bugs.
The web page is actually about reporting bugs. What about "for how to
Since I'm basically bikeshedding already: the macro expands into more
than just bug reporting. Call it QEMU_HELP_BOTTOM? Feel free to ignore
> + "More information on the qemu project at <http://qemu.org>"
> /* main function, renamed */
> #if defined(CONFIG_COCOA)
> int qemu_main(int argc, char **argv, char **envp);
Getting late for 2.10, but it's such a lovely little improvement...