On 2018-02-09 19:18, Max Reitz wrote: > On 2018-02-08 20:23, Kevin Wolf wrote: >> A few block drivers will need to rename .bdrv_create options for their >> QAPIfication, so let's have a helper function for that. >> >> Signed-off-by: Kevin Wolf <kw...@redhat.com> >> --- >> include/qapi/qmp/qdict.h | 6 ++++++ >> qobject/qdict.c | 30 ++++++++++++++++++++++++++++++ >> 2 files changed, 36 insertions(+) > > Hmmm, looks OK, but I wonder whether this is going to be any more > efficient than if we simply had a qdict_rename_key() function that you > call multiple times. > > ("efficient" both in terms of code readability and runtime efficiency) > > So, I'll give you a > > Reviewed-by: Max Reitz <mre...@redhat.com> > > and let you decide.
Ah, I see, error handling is much easier this way, that's right. OK, R-b stands then. Max
Description: OpenPGP digital signature