16.02.2018 01:01, Eric Blake wrote:
On 02/15/2018 07:51 AM, Vladimir Sementsov-Ogievskiy wrote:
NBD_REP_ERR_INVALID is often parameter to nbd_opt_drop and it would
be used more in following patches. So, let's add a helper.

Signed-off-by: Vladimir Sementsov-Ogievskiy <vsement...@virtuozzo.com>
  nbd/server.c | 50 ++++++++++++++++++++++++++++++++++++--------------
  1 file changed, 36 insertions(+), 14 deletions(-)

More than twice the lines added compared to what was removed, so it's a tough call whether this refactoring makes a common pattern easier or just adds burden in tracing what gets executed, just to remove a parameter.  I'm not opposed to the patch, but want to see how it helps the rest of the series.

At any rate, the conversion itself is done correctly, so if we keep the patch, it has earned:

Reviewed-by: Eric Blake <ebl...@redhat.com>

  +static int GCC_FMT_ATTR(4, 5)
+nbd_opt_drop(NBDClient *client, uint32_t type, Error **errp,
+             const char *fmt, ...)
+    int ret;
+    va_list va;
+    va_start(va, fmt);
+    ret = nbd_opt_vdrop(client, type, errp, fmt, va);
+    va_end(va);
+    return ret;
+static int GCC_FMT_ATTR(3, 4)
+nbd_opt_invalid(NBDClient *client, Error **errp, const char *fmt, ...)

No documentation comments?

the function is obvious and is near to nbd_opt_vdrop.. do we really want a comment? And, then, what about seprate comment for nbd_opt_drop?

Best regards,

Reply via email to