08.10.2019 12:03, Max Reitz wrote:
> On 07.10.19 19:10, Vladimir Sementsov-Ogievskiy wrote:
>> 07.10.2019 18:27, Max Reitz wrote:
>>> On 03.10.19 19:15, Vladimir Sementsov-Ogievskiy wrote:
>>>> Currently total allocation for parallel requests to block-copy instance
>>>> is unlimited. Let's limit it to 128 MiB.
>>>>
>>>> For now block-copy is used only in backup, so actually we limit total
>>>> allocation for backup job.
>>>>
>>>> Signed-off-by: Vladimir Sementsov-Ogievskiy <vsement...@virtuozzo.com>
>>>> ---
>>>>    include/block/block-copy.h | 3 +++
>>>>    block/block-copy.c         | 5 +++++
>>>>    2 files changed, 8 insertions(+)
>>>>
>>>> diff --git a/include/block/block-copy.h b/include/block/block-copy.h
>>>> index e2e135ff1b..bb666e7068 100644
>>>> --- a/include/block/block-copy.h
>>>> +++ b/include/block/block-copy.h
>>>> @@ -16,6 +16,7 @@
>>>>    #define BLOCK_COPY_H
>>>>    
>>>>    #include "block/block.h"
>>>> +#include "qemu/co-shared-amount.h"
>>>>    
>>>>    typedef struct BlockCopyInFlightReq {
>>>>        int64_t start_byte;
>>>> @@ -69,6 +70,8 @@ typedef struct BlockCopyState {
>>>>         */
>>>>        ProgressResetCallbackFunc progress_reset_callback;
>>>>        void *progress_opaque;
>>>> +
>>>> +    QemuCoSharedAmount *mem;
>>>>    } BlockCopyState;
>>>>    
>>>>    BlockCopyState *block_copy_state_new(BdrvChild *source, BdrvChild 
>>>> *target,
>>>> diff --git a/block/block-copy.c b/block/block-copy.c
>>>> index cc49d2345d..e700c20d0f 100644
>>>> --- a/block/block-copy.c
>>>> +++ b/block/block-copy.c
>>>> @@ -21,6 +21,7 @@
>>>>    #include "qemu/units.h"
>>>>    
>>>>    #define BLOCK_COPY_MAX_COPY_RANGE (16 * MiB)
>>>> +#define BLOCK_COPY_MAX_MEM (128 * MiB)
>>>>    
>>>>    static void coroutine_fn block_copy_wait_inflight_reqs(BlockCopyState 
>>>> *s,
>>>>                                                           int64_t start,
>>>> @@ -64,6 +65,7 @@ void block_copy_state_free(BlockCopyState *s)
>>>>        }
>>>>    
>>>>        bdrv_release_dirty_bitmap(s->source->bs, s->copy_bitmap);
>>>> +    qemu_co_shared_amount_free(s->mem);
>>>>        g_free(s);
>>>>    }
>>>>    
>>>> @@ -95,6 +97,7 @@ BlockCopyState *block_copy_state_new(BdrvChild *source, 
>>>> BdrvChild *target,
>>>>            .cluster_size = cluster_size,
>>>>            .len = bdrv_dirty_bitmap_size(copy_bitmap),
>>>>            .write_flags = write_flags,
>>>> +        .mem = qemu_co_shared_amount_new(BLOCK_COPY_MAX_MEM),
>>>>        };
>>>>    
>>>>        s->copy_range_size = QEMU_ALIGN_DOWN(max_transfer, cluster_size),
>>>> @@ -316,7 +319,9 @@ int coroutine_fn block_copy(BlockCopyState *s,
>>>>    
>>>>            bdrv_reset_dirty_bitmap(s->copy_bitmap, start, chunk_end - 
>>>> start);
>>>>    
>>>> +        qemu_co_get_amount(s->mem, chunk_end - start);
>>>
>>> Now that I see it like this, maybe the name is too short.  This sounds
>>> like it was trying to get some amount of coroutines.
>>>
>>> Would “qemu_co_get_from_shared_amount” be too long?  (Something like
>>> qemu_co_sham_alloc() would be funny, but maybe not.  :-)  Or maybe
>>> exactly because it”s funny.)
>>>
>>
>> hmm sham may be interpreted as shared memory, not only like shame..
> 
> “sham” is also a word by itself. :-)

Hmm didn't know, me go to google translate. OK, sham looks a lot nicer than 
shame)

> 
>> And if we call it _alloc, the opposite should be _free, but how to
>> distinguish it from freeing the whole object? Hmm, use create/destroy for
>> the whole object maybe.
>>
>> May be, drop "qemu_" ? It's not very informative. Or may be drop "co_"?.
>>
>> I don't like shaming my shared amount :)
> 
> It’s worse calling it all a sham.
> 
>> May be, we should imagine, what are we allocating? May be balls?
>>
>> struct BallAllocator
>>
>> ball_allocator_create
>> ball_allocator_destroy
>>
>> co_try_alloc_balls
>> co_alloc_balls
>> co_free_balls
>>
>> Or bars? Or which thing may be used for funny naming and to not intersect
>> with existing concepts like memory?
> 
> I love it (thanks for making my morning), but I fear it may be
> interpreted as risqué.
> 
> Maybe just shres for shared resource?  So alloc_from_shres?
> 

OK for me. But.. How to name _free function than?

struct SharedResource

shres_create
shres_destroy

co_try_alloc_from_shres
co_alloc_from_shres
co_free_???

co_free_res_alloced_from_shres ? :)

or

co_try_get_from_shres
co_get_from_shres
co_put_to_shres

>>>
>>>>            ret = block_copy_do_copy(s, start, chunk_end, error_is_read);
>>>> +        qemu_co_put_amount(s->mem, chunk_end - start);
>>>>            if (ret < 0) {
>>>>                bdrv_set_dirty_bitmap(s->copy_bitmap, start, chunk_end - 
>>>> start);
>>>>                break;
>>>>
>>>
>>>
>>
>>
> 
> 


-- 
Best regards,
Vladimir

Reply via email to