On Thu, Aug 20, 2020 at 06:58:47PM +0200, Philippe Mathieu-Daudé wrote:
> Use self-explicit SCALE_MS definition instead of magic value.
> 
> Reviewed-by: Stefan Hajnoczi <stefa...@redhat.com>
> Signed-off-by: Philippe Mathieu-Daudé <phi...@redhat.com>
> ---
>  block/nvme.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Reviewed-by: Stefano Garzarella <sgarz...@redhat.com>

> 
> diff --git a/block/nvme.c b/block/nvme.c
> index 374e2689157..2f5e3c2adfa 100644
> --- a/block/nvme.c
> +++ b/block/nvme.c
> @@ -715,7 +715,7 @@ static int nvme_init(BlockDriverState *bs, const char 
> *device, int namespace,
>      /* Reset device to get a clean state. */
>      s->regs->cc = cpu_to_le32(le32_to_cpu(s->regs->cc) & 0xFE);
>      /* Wait for CSTS.RDY = 0. */
> -    deadline = qemu_clock_get_ns(QEMU_CLOCK_REALTIME) + timeout_ms * 
> 1000000ULL;
> +    deadline = qemu_clock_get_ns(QEMU_CLOCK_REALTIME) + timeout_ms * 
> SCALE_MS;
>      while (le32_to_cpu(s->regs->csts) & 0x1) {
>          if (qemu_clock_get_ns(QEMU_CLOCK_REALTIME) > deadline) {
>              error_setg(errp, "Timeout while waiting for device to reset (%"
> -- 
> 2.26.2
> 
> 


Reply via email to