On 12/28/24 13:12, Helge Deller wrote:
On 12/28/24 12:16, BALATON Zoltan wrote:
static inline bool hppa_is_pa20(CPUHPPAState *env)
{
-    return object_dynamic_cast(OBJECT(env_cpu(env)), TYPE_HPPA64_CPU) != NULL;
+    return env->is_pa20;
}

Now this function name is longer than what it extends to so maybe it
would be simpler to drop the inline function and use env->is_pa20
directly where it's needed?

Yes, that's a possible cleanup which can be done afterwards.

Is there a reason to keep the function?

Personally I like it more than the "env->is_pa20".
Richard, any opinion from your side? Should I send a such a replacement patch?

I like keeping the accessor function.


r~

Reply via email to