On 15/4/25 21:25, Richard Henderson wrote:
Signed-off-by: Richard Henderson <[email protected]> --- include/tcg/tcg-opc.h | 15 ++++---------- tcg/optimize.c | 28 +++++++------------------ tcg/tcg-op.c | 14 ++++++------- tcg/tcg.c | 45 +++++++++++++--------------------------- tcg/tci.c | 36 +++++++++----------------------- tcg/tci/tcg-target.c.inc | 20 +++++++----------- 6 files changed, 50 insertions(+), 108 deletions(-)
diff --git a/tcg/optimize.c b/tcg/optimize.c index 1da23755e3..cbc519624a 100644 --- a/tcg/optimize.c +++ b/tcg/optimize.c @@ -30,14 +30,6 @@
@@ -2926,19 +2918,16 @@ static bool fold_tcg_st(OptContext *ctx, TCGOp *op) }switch (op->opc) {- CASE_OP_32_64(st8): + case INDEX_op_st8: lm1 = 0; break; - CASE_OP_32_64(st16): + case INDEX_op_st16: lm1 = 1; break; - case INDEX_op_st32_i64: - case INDEX_op_st_i32: + case INDEX_op_st32: lm1 = 3; break; - case INDEX_op_st_i64: - lm1 = 7; - break; + case INDEX_op_st: case INDEX_op_st_vec: lm1 = tcg_type_size(ctx->type) - 1; break;
Unrelated nitpicking comment while looking at what lm1 is, I'd find clearer for tcg_type_size() to return an unsigned type, and lm1 be a uintptr_t one. Matter of taste I suppose. Regardless, Reviewed-by: Philippe Mathieu-Daudé <[email protected]>
