On Mon, 1 Jul 2013 16:31:49 +0200 Kevin Wolf <kw...@redhat.com> wrote:
> v2: > - Updated documentation in patch 3 > > v3: > - Refactored differently (introduced get_expr()) as suggested by Michael > > Kevin Wolf (3): > qapi.py: Avoid code duplication > qapi.py: Allow top-level type reference for command definitions > qapi-schema: Use BlockdevSnapshot type for blockdev-snapshot-sync Applied to the qmp branch, thanks. Can you post an incremental patch to cover the drive-backup command as suggested by Eric? > > qapi-schema.json | 14 ++------------ > scripts/qapi.py | 37 ++++++++++++++++++++++++++++--------- > 2 files changed, 30 insertions(+), 21 deletions(-) >