11.02.2016 03:54, Wei Yang wrote:
> Use the macro PCI_CAP_LIST_NEXT instead of 1, so that the code would be
> more self-explain.
> 
> This patch makes this change and also fixs one typo in comment.
> 

>      for (tmp = pdev->config[PCI_CAPABILITY_LIST]; tmp;
> -         tmp = pdev->config[tmp + 1]) {
> +         tmp = pdev->config[tmp + PCI_CAP_LIST_NEXT]) {

> -    next = pdev->config[pos + 1];
> +    next = pdev->config[pos + PCI_CAP_LIST_NEXT];

Hmm. I'm not sure the new version is better, to me "+1" reads
easier than the new symbolic constant variant.

If it were something like pdev->config[PCI_CAP_LIST_NEXT], that'd be
nice, but not "pos + PCI_CAP_LIST_NEXT".

But again, I'm not pci config space expert and don't understand
the basics :)

Thanks,

/mjt

Reply via email to