On Tue, 2016-09-20 at 09:51 -0400, G 3 wrote:
> 
> > Is it worth renaming this to make it obvious that it is your
> > (non-optimal) replacement, intentionally because you don't want to
> > use
> > the libc version?
> 
> I originally thought about adding a prefix to all my functions. Ben  
> what do you think?
> I'm ok with either way.

DriverServicesLibrary has:

char *CStrCopy(char *dst, const char *src);
char *CStrNCopy (char *dst, const char *src, UInt32 max);
char *CStrCat (char *dst, const char *src);
char *CStrNCat (char *dst, const char *src, UInt32 max);
short CStrCmp (const char *str1, const char *str2);
short CStrNCmp (const char *str1, const char *str2, UInt32 max);
UInt32 CStrLen (const char *src);

Cheers,
Ben.


Reply via email to