"Dr. David Alan Gilbert" <dgilb...@redhat.com> wrote:
> * Juan Quintela (quint...@redhat.com) wrote:
>> Once there, rename the type to be shorter.
>> 
>> Signed-off-by: Juan Quintela <quint...@redhat.com>
>> ---
>>  migration/ram.c | 79 
>> ++++++++++++++++++++++++++++++---------------------------
>>  1 file changed, 42 insertions(+), 37 deletions(-)
>> 
>> diff --git a/migration/ram.c b/migration/ram.c
>> index c14293c..d39d185 100644
>> --- a/migration/ram.c
>> +++ b/migration/ram.c
>> @@ -132,6 +132,19 @@ out:
>>      return ret;
>>  }
>>  
>> +struct RAMBitmap {
>> +    struct rcu_head rcu;
>> +    /* Main migration bitmap */
>> +    unsigned long *bmap;
>> +    /* bitmap of pages that haven't been sent even once
>> +     * only maintained and used in postcopy at the moment
>> +     * where it's used to send the dirtymap at the start
>> +     * of the postcopy phase
>> +     */
>> +    unsigned long *unsentmap;
>> +};
>> +typedef struct RAMBitmap RAMBitmap;
>> +
>
> I'm OK with this; although I can see the idea of naming it BitmapRcu,
> given that the actual bmap is inside that and most of the rest of the type
> is just the rcu wrapper.

It is the type, and now it also has the unsentmap.

  atomic_rcu_read(&ram_state.bitmap_rcu)->bmap)

ends  getting really long quite fast "p"

> Reviewed-by: Dr. David Alan Gilbert <dgilb...@redhat.com>

Thanks, Juan.

Reply via email to