The crash has now been fixed here:
http://git.qemu.org/?p=qemu.git;a=commitdiff;h=aa612b364ecbe1dc
Please also note that the "-usbdevice serial" syntax is considered as 
deprecated nowadays - use "-device usb-serial" instead.

** Changed in: qemu
       Status: New => Fix Committed

-- 
You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.
https://bugs.launchpad.net/bugs/1180924

Title:
  fails to handle a usb serial port with a specific vendorid

Status in QEMU:
  Fix Committed

Bug description:
  If I run qemu-system-i386 with arguments
  -usb -usbdevice serial:vendorid=1221:pty
  (this is what the documentation says about how I shoud add a usb device which 
has a serial port interface and which has a specific vendor id, I used the 
documentation located here:
  http://qemu.weilnetz.de/qemu-doc.html
  ), it says 
  char device redirected to /dev/pts/<something> (label usbserial0)
  qemu-system-i386: -usbdevice serial:vendorid=1221:pty: Property '.vendorid' 
not found
  Aborted
  and exits. Moreover, if I try to add such a device to a running machine by 
typing usb_add serial:vendorid=1221:pty in the machine's control terminal (to 
reach it, I press ctrl-alt-2), qemu also writes 
  char device redirected to /dev/pts/<something> (label usbserial0)
  Aborted
  to the terminal where I run it from and exits. To the quest OS this looks 
like a power failure which causes all the programs inside the virtual machine 
to lose their unsaved data.
  I have tested this with qemu-1.5.0-rc2, actually, the issue occured in a 
similar way since 1.0.1, but did not occur in 0.11.1.
  The issue is reproducible always, even if I don't specify any hard disk in 
the command line, i. e.
  $ qemu-system-i386 -usb -usbdevice serial:vendorid=1221:pty
  , so I believe it is guest OS -independent.

To manage notifications about this bug go to:
https://bugs.launchpad.net/qemu/+bug/1180924/+subscriptions

Reply via email to