On 24.07.2017 20:00, Richard Henderson wrote: > On 07/24/2017 10:38 AM, David Hildenbrand wrote: >> On 24.07.2017 06:40, Richard Henderson wrote: >>> On 07/21/2017 05:56 AM, David Hildenbrand wrote: >>>> Signed-off-by: David Hildenbrand<da...@redhat.com> >>>> --- >>>> target/s390x/cpu.h | 14 ++++++++++++++ >>>> target/s390x/mem_helper.c | 14 -------------- >>>> 2 files changed, 14 insertions(+), 14 deletions(-) >>> >>> Reviewed-by: Richard Henderson <r...@twiddle.net> >>> >>> Although another header, private to the helpers, might be better... >>> >> >> Question is if we should have a new header for stuff really only used >> locally in target/s390x - in contrast to say cpu.h, which is included >> from various other places. So not only a header for helpers, but also >> used for e.g. kvm.c. >> >> This header could e.g. be called cpu_helper.h and would not included in >> cpu.h > > C.f. target/arm/internals.h, which is a bit better as a name, I think. > Perhaps something to wait for 2.11 tree though, and we'll do it proper. > > > r~ >
Sounds good to me. -- Thanks, David