On 01/07/2011 03:35 PM, Stuart Brady wrote:
>> +static inline void tcg_out_depi(TCGContext *s, int ret, int arg,
> ^^^
>> + unsigned ofs, unsigned len)
>> +{
>> + assert(ofs < 32 && len <= 32 - ofs);
>> + tcg_out32(s, INSN_DEPI | INSN_R2(ret) | INSN_IM5(val)
> ^^^
>
> The parameter should be named val, too.
Oops. It seems I failed to push that trivial change back from the gcc farm
test box.
>> + if (const_args[1]) {
>
> Surely const_args[1] && arg1 == 0?
This is implied by the "Z" constraint used.
r~