We want to limit the use of the term 'size' for only values that count by bytes. Renaming fields in the spec does not invalidate any existing implementation, but may make future implementations easier to write.
A reasonable followup would be to rename internal qemu code that operates on qcow2 images to also use the distinction between size and entries in variable names. Signed-off-by: Eric Blake <ebl...@redhat.com> --- docs/interop/qcow2.txt | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/docs/interop/qcow2.txt b/docs/interop/qcow2.txt index d7fdb1fee31..597d3f261d5 100644 --- a/docs/interop/qcow2.txt +++ b/docs/interop/qcow2.txt @@ -47,7 +47,7 @@ The first cluster of a qcow2 image contains the file header: 1 for AES encryption 2 for LUKS encryption - 36 - 39: l1_size + 36 - 39: l1_entries Number of entries in the active L1 table 40 - 47: l1_table_offset @@ -538,7 +538,7 @@ Structure of a bitmap directory entry: (described below) for the bitmap starts. Must be aligned to a cluster boundary. - 8 - 11: bitmap_table_size + 8 - 11: bitmap_table_entries Number of entries in the bitmap table of the bitmap. 12 - 15: flags -- 2.14.3