On 02/14/2018 03:51 PM, Collin L. Walling wrote:
> On 02/06/2018 05:13 AM, Viktor Mihajlovski wrote:
>> On 06.02.2018 10:23, Thomas Huth wrote:
>>> On 05.02.2018 21:57, Collin L. Walling wrote:
>>> [...]
>>>> diff --git a/pc-bios/s390-ccw/main.c b/pc-bios/s390-ccw/main.c
>>>> index e857ce4..825a1a3 100644
>>>> --- a/pc-bios/s390-ccw/main.c
>>>> +++ b/pc-bios/s390-ccw/main.c
>>>> @@ -16,6 +16,7 @@ char stack[PAGE_SIZE * 8] 
>>>> __attribute__((__aligned__(PAGE_SIZE)));
>>>>   static SubChannelId blk_schid = { .one = 1 };
>>>>   IplParameterBlock iplb __attribute__((__aligned__(PAGE_SIZE)));
>>>>   static char loadparm[8] = { 0, 0, 0, 0, 0, 0, 0, 0 };
>>>> +QemuIplParameters qipl;
>>>>     /*
>>>>    * Priniciples of Operations (SA22-7832-09) chapter 17 requires that
>>>> @@ -81,6 +82,7 @@ static void virtio_setup(void)
>>>>       uint16_t dev_no;
>>>>       char ldp[] = "LOADPARM=[________]\n";
>>>>       VDev *vdev = virtio_get_device();
>>>> +    QemuIplParameters *early_qipl = (QemuIplParameters *)204;
>>> Could you please introduce a proper #define for that magic 204 value
>>> (and use it in s390_ipl_prepare_qipl, too)? ... so that it is later
>>> easier to grep for this.
>>>
>> Hm ... I was following the pattern established in
>> write_subsystem_identification(). Christian, what is your opinion?
> 
> Any updates on this?  Last change I need to make before the next post.

Let's use a magic number. It is the preferred way in QEMU.


Reply via email to