yep, it's been giving errors now for a while (and not hanging) and also
recently gained the error text in 'info migrate':

[dgilbert@dgilbert-t530 ~]$ /usr/bin/qemu-system-x86_64 -nographic
QEMU 2.10.1 monitor - type 'help' for more information
(qemu) migrate tcp:0:12345
qemu-system-x86_64: Failed to connect socket: Connection refused
(qemu) info migrate
globals: store-global-state=1, only_migratable=0, send-configuration=1, 
send-section-footer=1
capabilities: xbzrle: off rdma-pin-all: off auto-converge: off zero-blocks: off 
compress: off events: off postcopy-ram: off x-colo: off release-ram: off block: 
off return-path: off 
Migration status: failed (Failed to connect socket: Connection refused)
total time: 0 milliseconds
(qemu) 

So marking as fix-release

(Note that there's a bug that causes a crash in the disconnect case on
current head, but that's only been in for a week or so and I've just
sent a fix for it).

-- 
You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.
https://bugs.launchpad.net/bugs/589315

Title:
  qemu: Improve error reporting when migration can't connect

Status in QEMU:
  In Progress

Bug description:
  Tested with upstream qemu as of Jun 3 2010

  If the source qemu instance can't connect to the migration destination (say
  there is no listening QEMU instance, or port is blocked by a firewall), all we
  get is info migrate -> Migration status: failed. This is all we have to report
  back to libvirt users if their firewall is misconfigured, which is crappy.

  Ideally, if we can't connect, migration would fail immediately with a relevant
  message and strerror(). More info from 'info migrate' would be nice too, no
  idea how this will play with QMP though.

  As a slightly related issue, try entering

  migrate tcp:127.0.0.0:6000

  We get a 'migration failed' error, and then the monitor hangs!

To manage notifications about this bug go to:
https://bugs.launchpad.net/qemu/+bug/589315/+subscriptions

Reply via email to