Richard Henderson <richard.hender...@linaro.org> writes: > On 02/22/2018 09:23 AM, Alex Bennée wrote: >> >> Richard Henderson <richard.hender...@linaro.org> writes: >> >>> On 02/08/2018 09:31 AM, Alex Bennée wrote: >>>> + maxpasses = hp ? (is_q ? 8 : 4) : (is_q ? 4 : 2); >>> >>> (8 << is_q) >> size >>> >>> ? >> >> Hmm I'm not so sure about this. While mine is longer form at least the >> intent is clear. What about: >> >> maxpasses = (is_q ? 4 : 2) << hp >> >> It's still a little magical IMHO though... > > Two variables then? > > vector_size = 8 << is_q; > maxpasses = vector_size >> size; > > Why do you want the "hp" variable when you already have "size"?
Well I had introduced hp for: genfn = hp ? gen_helper_advsimd_cgt_f16 : gen_helper_neon_cgt_f32; Instead of having it long form. I guess it could be neater though. -- Alex Bennée