I wonder - would be a record using rr of any help? I can create record
for QEMU 1.2.0 where it works and on current QEMU.

Also, I did a bit of debugging myself around the DMA code as per comment
#3 it was introduced in a commit that changed some of the DMA. What I
did was that I added some debug printfs [1] to dma_memory_rw() to QEMU
1.2.0 and to QEMU 2.11.1.

I noticed on thing - there is a big difference between writes between the two 
Because this stuff is completely outside my knowledge, I don't know whether 
this is important or not, but better more information that not enough. For 
recent versions of QEMU I see a few 16 B writes from address 0x6d10 and 
addresses close to it which contain some data. Immediately after that there is 
a ton of 8B writes from addresses starting at 0x102004 which contain zeros 
only. On the other hand, the QEMU 1.2.0 is missing the initial 16B writes, but 
then there's even more 8B writes from addresses around 0x102004 which contain 
some data instead of zeros like in the current version.

[1] the printf looks like this:

printf("DEBUG: DMA %s at address %lx %lu bytes: ", ((dir ==
DMA_DIRECTION_FROM_DEVICE) ? "read" : "write"), addr, len);

You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.

  QNX 4 doesn't boot on qemu >= 1.3

Status in QEMU:

Bug description:
  I am using virtual machine with QNX4 operating system installed on it.  I 
updated my qemu from version
  to newer and QNX4 doesn't start any more. All is ok on version 1.2 but when I 
try to use any newer version
  (1.3, 1.4, 1.5)  QNX4 doesn't boot.  I tried on windows and linux ubuntu 
hosts - effects are the same.

  When virtual machine boots qnx bootloader loads and starts operating system. 
In the next step
  qnx starts its ide driver, which detects qemu harddisk and cdrom. Problem 
starts when operating system
  tries mount partition - an error occur and qnx stop booting procedure:

  mount -p "No bios signature in partition sector on /dev/hd0"

  I have tried install qnx from cdrom but it seems that there is the same 
problem. QNX installer boot from
  cdrom, detects hard disk and cdrom, but cdrom can't be mounted in the next 
step of installation procedure.

To manage notifications about this bug go to:

Reply via email to