On 16 May 2018 at 21:55, Laurent Vivier <laur...@vivier.eu> wrote:
> to be like in the kernel and rename it TARGET_ARCH_HAS_SOCKET_TYPES
>
> Signed-off-by: Laurent Vivier <laur...@vivier.eu>

> +/* Flags for socket, socketpair, accept4 */
> +#define TARGET_SOCK_CLOEXEC    TARGET_O_CLOEXEC
> +#ifndef TARGET_SOCK_NONBLOCK
> +#define TARGET_SOCK_NONBLOCK   O_NONBLOCK

Shouldn't this be TARGET_O_NONBLOCK ?

>  #endif
> +#endif /* TARGET_ARCH_HAS_SOCKET_TYPES */

thanks
-- PMM

Reply via email to