On 21/05/2019 14:54, Daniel P. Berrangé wrote:
On Tue, May 21, 2019 at 02:52:42PM +0200, Laurent Vivier wrote:
On 21/05/2019 13:52, Daniel P. Berrangé wrote:
On Wed, May 15, 2019 at 10:50:30PM +0200, Paolo Bonzini wrote:
From: Laurent Vivier <lviv...@redhat.com>
Some objects are only needed for system emulation and tools.
We can ignore them for the user mode case
Update tests to run accordingly: conditionally build some tests
Some tests use components that are only built when softmmu or
block tools are enabled, not for linux-user. So, if these components
are not available, disable the tests.
Signed-off-by: Laurent Vivier <laur...@vivier.eu>
Makefile | 4 +++
Makefile.objs | 14 +++++---
tests/Makefile.include | 90
3 files changed, 58 insertions(+), 50 deletions(-)
diff --git a/Makefile b/Makefile
index 1851f8c..155f066 100644
@@ -87,6 +87,10 @@ endif
+# notempy and lor are defined in rules.mak
+CONFIG_TOOLS := $(call notempty,$(TOOLS))
+CONFIG_BLOCK := $(call lor,$(CONFIG_SOFTMMU),$(CONFIG_TOOLS))
IMHO calling this CONFIG_BLOCK is a really poor choice, as
the decision is completely unrelated to block modules. It
made really confused when trying to understand why all the
crypto or auth code had been made conditional on the block
drivers. The block code is just one part of QEMU that
is used in tools & softmmu.
It would be better as CONFIG_SOFTMMU_TOOLS, or
CONFIG_NOT_USER, or something else.
Do you think it's worth a patch to change the name?
Personally I'd like to see a patch to give it a better name.
I'm wondering which name to use.
CONFIG_NOT_USER is not correct because the flag can be 'y' with
CONFIG_SOFTMMU_TOOLS is too fuzzy.