On 11/10/2019 10.03, Max Reitz wrote:
> On 11.10.19 09:27, Thomas Huth wrote:
>> On 10/10/2019 17.24, Max Reitz wrote:
>>> Hi,
>>> Perhaps the main reason we cannot run important tests such as 041 in CI
>>> is that when they care Unix sockets in $TEST_DIR, the path may become
>>> too long to connect to them.
>>> To get by this problem, this series lets the check script create a new
>>> temporary directory (mktemp -d) and then makes the iotests use it for
>>> all Unix sockets.
>> Thanks a lot for tackling this!
>> I gave it a try, and most tests work fine now indeed when I run them in
>> a directory with a veeeery long file name.
>> I still get an error with 028 though:
> Hm, I didn’t see any error for 028 or 055 myself.  028 makes use of
> common.qemu, which uses FIFOs, and I thought there were exempt from this
> problem.  And for 055 I have no idea.
> Maybe just bugs in qemu? :-)

Yeah, maybe... anyway, both, 028 and 055, are not in the auto group, so
I think we simply could ignore these bugs for now.


Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to