On Tue, 3 Nov 2020 12:08:20 +0100 Philippe Mathieu-Daudé <phi...@redhat.com> wrote:
> On 11/3/20 11:45 AM, Cornelia Huck wrote: > > On Tue, 3 Nov 2020 06:49:13 +0100 > > Philippe Mathieu-Daudé <phi...@redhat.com> wrote: > > > >> Hi Matthew, > >> > >> On 11/1/20 10:02 PM, Alex Williamson wrote: > >>> From: Matthew Rosato <mjros...@linux.ibm.com> > >>> > >>> Create new files for separating out vfio-specific work for s390 > >>> pci. Add the first such routine, which issues VFIO_IOMMU_GET_INFO > >>> ioctl to collect the current dma available count. > >>> > >>> Signed-off-by: Matthew Rosato <mjros...@linux.ibm.com> > >>> Reviewed-by: Cornelia Huck <coh...@redhat.com> > >>> [aw: Fix non-Linux build with CONFIG_LINUX] > >>> Signed-off-by: Alex Williamson <alex.william...@redhat.com> > >>> --- > >>> hw/s390x/meson.build | 1 + > >>> hw/s390x/s390-pci-vfio.c | 54 > >>> ++++++++++++++++++++++++++++++++++++++ > >>> include/hw/s390x/s390-pci-vfio.h | 24 +++++++++++++++++ > >>> 3 files changed, 79 insertions(+) > >>> create mode 100644 hw/s390x/s390-pci-vfio.c > >>> create mode 100644 include/hw/s390x/s390-pci-vfio.h > >>> > >>> diff --git a/hw/s390x/meson.build b/hw/s390x/meson.build > >>> index 948ceae7a7b3..f4663a835514 100644 > >>> --- a/hw/s390x/meson.build > >>> +++ b/hw/s390x/meson.build > >>> @@ -27,6 +27,7 @@ s390x_ss.add(when: 'CONFIG_KVM', if_true: files( > >>> )) > >>> s390x_ss.add(when: 'CONFIG_S390_CCW_VIRTIO', if_true: > >>> files('s390-virtio-ccw.c')) > >>> s390x_ss.add(when: 'CONFIG_TERMINAL3270', if_true: files('3270-ccw.c')) > >>> +s390x_ss.add(when: 'CONFIG_LINUX', if_true: files('s390-pci-vfio.c')) > > > > I think we need s/CONFIG_LINUX/CONFIG_VFIO/ here. > > With your change: > > hw/s390x/s390-pci-bus.c:1079: undefined reference to > `s390_pci_end_dma_count' > hw/s390x/s390-pci-bus.c:1019: undefined reference to > `s390_pci_start_dma_count' > hw/s390x/s390-pci-bus.c:1021: undefined reference to `s390_pci_get_clp_info' > > Do we need stubs instead? > We do have stubs; we just need them to be ifdeffed with CONFIG_VFIO instead of CONFIG_LINUX. Currently preparing a proper patch.