On 08/30/2011 02:24 PM, Blue Swirl wrote:
On Mon, Aug 29, 2011 at 2:55 PM, Anthony Liguori<aligu...@us.ibm.com> wrote:
This has been discussed before in the past. The special casing really makes no
sense anymore. This seems like a good change to make for 1.0.
Signed-off-by: Anthony Liguori<aligu...@us.ibm.com>
---
Makefile | 5 ++---
Makefile.target | 4 ----
2 files changed, 2 insertions(+), 7 deletions(-)
diff --git a/Makefile b/Makefile
index 8606849..51ecdb5 100644
--- a/Makefile
+++ b/Makefile
@@ -365,9 +365,8 @@ tar:
rm -rf /tmp/$(FILE)
SYSTEM_TARGETS=$(filter %-softmmu,$(TARGET_DIRS))
-SYSTEM_PROGS=$(patsubst qemu-system-i386,qemu, \
- $(patsubst %-softmmu,qemu-system-%, \
- $(SYSTEM_TARGETS)))
+SYSTEM_PROGS=$(patsubst %-softmmu,qemu-system-%, \
+ $(SYSTEM_TARGETS))
Maybe the patsubst could be avoided, just rename the build directory
from *-softmmu to qemu-system-* while at it?
USER_TARGETS=$(filter %-user,$(TARGET_DIRS))
USER_PROGS=$(patsubst %-bsd-user,qemu-%, \
Also here the directory and executable names could be made to match.
I thought that historically the phrase softmmu was for the variant of
libcpu that had an emulated TLB.
I know Peter's been talking about a linux-user mode that uses softmmu
since certain combinations of architectures today are impossible with
linux-user (ia64 on x86_64 for instance).
So I think the current naming conventions probably are reasonable
although I'm not opposed to changing them. I think that should be a
separate patch though.
Regards,
Anthony Liguori
diff --git a/Makefile.target b/Makefile.target
index 07af4d4..29287ed 100644
--- a/Makefile.target
+++ b/Makefile.target
@@ -27,12 +27,8 @@ ifdef CONFIG_USER_ONLY
QEMU_PROG=qemu-$(TARGET_ARCH2)
else
# system emulator name
-ifeq ($(TARGET_ARCH), i386)
-QEMU_PROG=qemu$(EXESUF)
-else
QEMU_PROG=qemu-system-$(TARGET_ARCH2)$(EXESUF)
endif
-endif
PROGS=$(QEMU_PROG)
STPFILES=
--
1.7.4.1