Hi,

On 5/19/21 3:45 PM, Philippe Mathieu-Daudé wrote:
'nproc' is not available on FreeBSD:

   $ JOBS=$(expr $(nproc) + 1)
   bash: line 119: nproc: command not found
   expr: syntax error

Instead, use 'sysctl -n hw.ncpu'.

Signed-off-by: Philippe Mathieu-Daudé <f4...@amsat.org>
---
  .gitlab-ci.d/buildtest-template.yml | 12 +++++++++++-
  1 file changed, 11 insertions(+), 1 deletion(-)

diff --git a/.gitlab-ci.d/buildtest-template.yml 
b/.gitlab-ci.d/buildtest-template.yml
index 58b01744751..fe4f18595ac 100644
--- a/.gitlab-ci.d/buildtest-template.yml
+++ b/.gitlab-ci.d/buildtest-template.yml
@@ -1,6 +1,16 @@
  .environment_variables_template:
    before_script:
-    - JOBS=$(expr $(nproc) + 1)
+    - if
+        test $(uname) = "FreeBSD"
+        ;
+      then
+        JOBS=$(sysctl -n hw.ncpu)
+        ;
+      else
+        JOBS=$(expr $(nproc) + 1)
+        ;
+      fi
+    - echo "=== Using $JOBS simultaneous jobs ==="

It has grown to beyond variables definitions. I suggest to rename it to something like `.before_script_template` (pure creativity, see?).

- Wainer

.native_build_job_template:
    stage: build


Reply via email to