On Tuesday, October 4, 2022 10:56:44 PM CEST Christian Schoenebeck wrote:
> This series converts relevant 9p (test) client functions to use named
> function arguments. For instance
> 
>     do_walk_expect_error(v9p, "non-existent", ENOENT);
> 
> becomes
> 
>     twalk({
>         .client = v9p, .path = "non-existent", .expectErr = ENOENT
>     });
> 
> The intention is to make the actual 9p test code more readable, and easier
> to maintain on the long-term.
> 
> Not only makes it clear what a literal passed to a function is supposed to
> do, it also makes the order and selection of arguments very liberal, and
> allows to merge multiple, similar functions into one single function.
> 
> This is basically just refactoring, it does not change behaviour.

Queued on 9p.next:
https://github.com/cschoenebeck/qemu/commits/9p.next

Thanks!

Next 9p PR end of this week.

Best regards,
Christian Schoenebeck




Reply via email to