I'm confused about the correct naming for this possibly duplicated

In the base class QgsDataProvider, we have and empty (returns 0):
virtual uint subLayerCount() const

but, in the providers code we have a mix of layerCount and subLayersCount,
the former is not virtual.

IMHO, we should use the base class virtual subLayersCount and rename all
the providers layerCount to override the subLayersCount.

Alessandro Pasotti
w3:   www.itopen.it
QGIS-Developer mailing list
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer

Reply via email to