Hi all,

Il 13/02/20 14:38, Richard Duivenvoorde ha scritto:
> 
> 
> On 13/02/2020 14.22, Jeff McKenna wrote:
>> Hi Paolo,
>>
>> It would be good to get the exact request that your server is sending to
>> MapServer, to debug this. (maybe using Fiddler, as described in the
>> steps I've recorded at
>> https://github.com/mapserver/mapserver/wiki/Get-the-Raw-WMS-Request-Generated-by-QGIS
>> )
> 
> @Jeff: my I plug this plugin:
> https://plugins.qgis.org/plugins/qgisnetworklogger/
> to view wfs/wms requests from within QGIS Desktop? You can see all
> requests en response info, AND replay in browser or curl
> 
> @Paolo: the error you see is when Minnesota mapserver is not receiving
> the full url (including the &map=mymapfile. So looks to me like QGIS
> server is handling the server-url different then QGIS desktop.
> I would try to connect to a local mapserver and log the apache requests
> there?

Indeed, adding
?SERVICE=WMS&REQUEST=GetCapabilities
returns valid results.
curl from the same server downloads a valid image.
Unclear therefore why the layers are shown in desktop and not in the
server. Could it be that they do not allow wms cascading?
I worked around this by taking data directly from wms, without passing
from qgis server, but it would be nice to understand this behaviour.
Thanks Richard for the plugin, very useful.
Cheers.
-- 
Paolo Cavallini - www.faunalia.eu
QGIS.ORG Chair:
http://planet.qgis.org/planet/user/28/tag/qgis%20board/
_______________________________________________
QGIS-Developer mailing list
QGIS-Developer@lists.osgeo.org
List info: https://lists.osgeo.org/mailman/listinfo/qgis-developer
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-developer

Reply via email to