Carson,

I find that the plugin works for me on OSX with the analysis branch, but not in trunk. Trunk spits out this error:

An error has occured while executing Python code:

Traceback (most recent call last):
File "/Users/jctull/.qgis//python/plugins/manageR/manageR.py", line 28, in run
    import manageRDialog
File "/Users/jctull/.qgis//python/plugins/manageR/ manageRDialog.py", line 6, in from QLayerConverter import QVectorLayerConverter, QRasterLayerConverter File "/Users/jctull/.qgis//python/plugins/manageR/ QLayerConverter.py", line 6, in
    import rpy2.robjects as robjects
File "/Library/Python/2.5/site-packages/rpy2/robjects/__init__.py", line 12, in
    import rpy2.rinterface as rinterface
File "/Library/Python/2.5/site-packages/rpy2/rinterface/ __init__.py", line 6, in
    R_HOME = os.popen("R RHOME").readlines()
IOError: [Errno 4] Interrupted system call

Python version:
2.5.1 (r251:54863, Jan 13 2009, 10:26:13)
[GCC 4.0.1 (Apple Inc. build 5465)]

John

On Mar 29, 2009, at 5:26 PM, Carson Farmer wrote:

Hello listers,

I am pleased to announce a new version of manageR is now available in my plugin repository (http://www.ftools.ca/cfarmerQgisRepo.xml or via the plugin installer using 3rd party repos). I am particularly happy with this version, as I think it is a major improvement over the older manageR. The interface is cleaner, and the console is more like a proper R console, so R users will likely find it easier to use. Multi-line commands can be entered line by line, or pasted into the console (type Ctrl+H in the console to see usage details), and layers can be imported and exported to and from manageR using simple keyboard commands.

This plugin is still in relatively early stages of development, but it should be safe enough to not destroy your data ;-) If you would like to help me improve manageR, and make it more stable, please report any bugs or suggestions using my google-code site: http://code.google.com/p/ftools-qgis/ or if you prefer, you can email me at: carson_dot_farmer_at_gmail_dot_com. I will also add more information to http://www.ftools.ca/manageR.html over the next few days.

Requirements:

QGIS version 1.x -> http://www.qgis.org/index.php
Rpy2 version 2.0.3 -> http://rpy.sourceforge.net/rpy2.html
R version 2.7.1 or higher (>= 2.8.0 recommended) -> http://www.r-project.org/
Numpy version 1.x.x -> http://numpy.scipy.org/


Cheers,


Carson

--
Carson J. Q. Farmer
ISSP Doctoral Fellow
National Centre for Geocomputation (NCG),
National University of Ireland, Maynooth,
Email: carson.far...@gmail.com
Web:   http://www.carsonfarmer.com/
     http://www.ftools.ca/

_______________________________________________
Qgis-user mailing list
Qgis-user@lists.osgeo.org
http://lists.osgeo.org/mailman/listinfo/qgis-user

_______________________________________________
Qgis-user mailing list
Qgis-user@lists.osgeo.org
http://lists.osgeo.org/mailman/listinfo/qgis-user

Reply via email to