Hi Chris,

I know we had to change fields called "location" and "name" to something else 
("location_desc" and "xx_name") when loading data into PostgreSQL in our 
thirdparty web GIS system.  This was then read by Geoserver and it complained 
about the reserved words.  I'm not sure what version of Geoserver it is as it 
is managed by our thirdparty supplier.

Ross

From: Qgis-user [mailto:qgis-user-boun...@lists.osgeo.org] On Behalf Of Chris 
Buckmaster
Sent: 22 August 2016 15:43
To: qgis-user@lists.osgeo.org
Subject: Re: [Qgis-user] Problems with adding WFS layers

I now believe this might be an issue with the use of 'location' as a column 
name - it loads ok using WFS 1.0.0 but 1.1.0 and 2.0.0 it does not load.

Did anything change in the specification between 1.0.0 and 1.1.0 to not allow 
these reserved word types as normal columns? Are there work arounds for this 
issue or would I need to rename any columns using 'location'? Is this a bug in 
v2.16 or just a change in the WFS standard?

From: Qgis-user [mailto:qgis-user-boun...@lists.osgeo.org] On Behalf Of Chris 
Buckmaster
Sent: 22 August 2016 14:51
To: qgis-user@lists.osgeo.org<mailto:qgis-user@lists.osgeo.org>
Subject: [Qgis-user] Problems with adding WFS layers

Hi


Not sure if this is a QGIS or Geoserver issue...

I have a WFS provided through Geoserver v2.5 - I have no issues adding layers 
from the WFS using QGIS v2.14, but in QGIS v2.16 I am encountering some 
problems with a selection of layers (within a specific Geoserver store).

The store which holds the layers that are not loading has the 'Expose primary 
keys' option ticked whereas others do not that are loading ok (I need to expose 
the primary keys), would this cause any problems? Below is the error I am 
getting when trying to access layers from this store...

2016-08-22T14:44:41 1 Server generated an exception in GetFeature response: 
java.lang.RuntimeException: Failed to get property: axisLabels
Failed to get property: axisLabels
java.lang.String cannot be cast to com.vividsolutions.jts.geom.Geometry
2016-08-22T14:44:41 1 Download of features for layer 
planning:tree_preservation_orders failed or partially failed: Server generated 
an exception in GetFeature response: java.lang.RuntimeException: Failed to get 
property: axisLabels
Failed to get property: axisLabels
java.lang.String cannot be cast to com.vividsolutions.jts.geom.Geometry. You 
may attempt reloading the layer with F5


Chris



This message is strictly confidential. If you have received this in error, 
please inform the sender and remove it from your system. If received in error 
you may not copy, print, forward or use it or any attachment in any way. This 
message is not capable of creating a legal contract or a binding representation 
and does not represent the views of Angus Council. Emails may be monitored for 
security and network management reasons. Messages containing inappropriate 
content may be intercepted. Angus Council does not accept any liability for any 
harm that may be caused to the recipient system or data on it by this message 
or any attachment.
_______________________________________________
Qgis-user mailing list
Qgis-user@lists.osgeo.org
List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user

Reply via email to