Hi all.

I have tried several ways to get QGIS with GRASS browser working. I had it
working at one point on Linux Mint 17/Trusty, but always with mixed results
(I could never get it working from the repos, but sometimes it would work
compiling from source). I did a fresh install of linux Mint 18, and I am
coming up with these results.

Tried ubuntugis-unstable repo. Installed all qgis/grass related packages -
cant browse GRASS locations

Added repo from qgis.org for 2.16 debian builds. Installed all qgis/grass
related packages - cant browse GRASS locations

Source: (followed this page https://github.com/qgis/QGIS/blob/master/INSTALL
Compiled from source, and installed in home directory - cant browse GRASS
locations. I could see it linking the grass libraries during compilation
and it seems it built ok, but I dont know how to check and make sure.

Built .deb packages from source and installed (using above web link) - with
this one the GRASS browser plugin was working, but any attempt to load
other plugins resulted in an error (cant load module xyz). Building the
.deb packages had errors, but not sure how to address them.

Interestingly, when I compile from source, then go into the /output/bin
directory and run qgis from there, it launches and the GRASS browser works.

Since grass 7, I've always had hit and miss results with QGIS and the GRASS
browser. This is one feature I really enjoy and find great value in getting
QGIS and GRASS to work together.

Any suggestions on what I can do to see what I'm doing wrong?

Qgis-user mailing list
List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user

Reply via email to