I am unable to run saga gis algorithms in qgis 2.16 from kyngchaos.com.

here is the first part of the error log. the list won't let me post the
whole thing

I tried using saga_cmd from the commandline and I get the same error
(Segmentation Fault: 11)

Any suggestions?

Process:               saga_cmd [39334]
Path:                  /Applications/QGIS.app/Contents/MacOS/bin/saga_cmd
Identifier:            saga_cmd
Version:               0
Code Type:             X86-64 (Native)
Parent Process:        sh [39333]
Responsible:           saga_cmd [39334]
User ID:               501

Date/Time:             2016-10-24 09:55:04.321 -0600
OS Version:            Mac OS X 10.11.6 (15G1004)
Report Version:        11
Anonymous UUID:        613CB97F-11FB-094F-F756-81879049F613

Sleep/Wake UUID:       DE2F58CC-2486-459A-AB9B-176C4D3A68BA

Time Awake Since Boot: 1500000 seconds
Time Since Wake:       690000 seconds

System Integrity Protection: disabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000010
Exception Note:        EXC_CORPSE_NOTIFY

VM Regions Near 0x10:
    __TEXT                 00000001093b9000-00000001093c9000 [   64K]
r-x/rwx SM=COW  /Applications/QGIS.app/Contents/MacOS/bin/saga_cmd

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libsaga_api.dylib             0x000000010944fdbb
CSG_Projections::WKT_to_Proj4(CSG_String&, CSG_String const&) const + 4671
1   libsaga_api.dylib             0x000000010944de55
CSG_Projection::Assign(CSG_String const&, ESG_Projection_Format) + 555
2   libio_gdal.dylib               0x000000010aef975c
CSG_GDAL_DataSet::Read(int) + 588
3   libio_gdal.dylib               0x000000010aefe8fa
CGDAL_Import::Load(CSG_GDAL_DataSet&, CSG_String const&) + 2794
4   libio_gdal.dylib               0x000000010aefdcbb
CGDAL_Import::On_Execute() + 435
5   libsaga_api.dylib             0x0000000109425c2f CSG_Module::Execute()
+ 93
6   saga_cmd                       0x00000001093bc9c4
CCMD_Module::Execute(int, char**) + 606
7   saga_cmd                       0x00000001093c1cea Execute(int, char**)
+ 513
8   saga_cmd                       0x00000001093c0a29 Run(int, char**) + 374
9   saga_cmd                       0x00000001093c0838 main + 49
10  libdyld.dylib                 0x00007fff8b40d5ad start + 1

Thread 0 crashed with X86 Thread State (64-bit):
  rax: 0x0000000000000000  rbx: 0x00007fcbd55840a0  rcx: 0x00007fcbd5577280
 rdx: 0x0000000000078590
  rdi: 0x000000010a7efa00  rsi: 0x000000010a7efa00  rbp: 0x00007fff56845cd0
 rsp: 0x00007fff568456e0
   r8: 0x0000000000000003   r9: 0x0000000000000000  r10: 0x0000000000000004
 r11: 0x00007fcbd5500000
  r12: 0x00000001094eebd0  r13: 0x00007fff56846698  r14: 0x00007fcbd5583c80
 r15: 0x00007fff56845ed8
  rip: 0x000000010944fdbb  rfl: 0x0000000000010282  cr2: 0x0000000000000010

Logical CPU:     0
Error Code:      0x00000004
Trap Number:     14
Qgis-user mailing list
List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user

Reply via email to