On Mon, 2016-10-31 at 23:12 +0800, Tim Bowden wrote:
> Worked fine for QGIS 2.16 but not 2.18: Can't do "graduated"
> classification for the style as per the tutorial (http://docs.qgis.or
> g/
> testing/en/docs/training_manual/vector_classification/classification.
> ht
> ml#moderate-fa-ratio-classification)
> When I pick "graduated", it won't let me pick any field apart
> from OGC_FID.  When I use the expression editor to chose another
> field,
> it reverts to blank field once I press OK in the expression dialogue.
>  I've tried this with my modified landuse.sqlite file (with new
> 'area'
> field as per tutorial) and with a fresh copy.
> Have I done something wrong or is this a fresh bug for 2.18?

OK, so more on this: Seemsqgis got confused somewhere.  Tried to add
another field to the sqlite layer and it threw an error:

Could not commit changes to layer landuse

Errors: SUCCESS: 1 attribute(s) added.
  ERROR: field with index 26 is not the same!
  Provider: spatialite
  Storage: SQLite database with SpatiaLite extension
  expected field: name=area type=QString typeName=TEXT len=0
  retrieved field: name=area type=double typeName=float len=0

I had to delete the connection to the layer and recreate it and the
problem disappeared.

Tim Bowden
Qgis-user mailing list
List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user

Reply via email to