Hi,

I am trying to build QGIS 2.18.0 from source in a Linux Opensuse Leap 42.2
machine, and I am consistenly getting the error below. I am building with
python 3 and without qt5 support.

[ 96%] Generating ui_widgetInfo.py
Traceback (most recent call last):
  File "../../../../../scripts/pyuic-wrapper.py", line 26, in <module>
    import qgis.PyQt.uic.pyuic
  File "/usr/local/src/qgis-2.18.0/build/output/python/qgis/__init__.py",
line 26, in <module>
    from qgis.PyQt import QtCore
  File
"/usr/local/src/qgis-2.18.0/build/output/python/qgis/PyQt/QtCore.py", line
60, in <module>
    QPyNullVariant.__nonzero__ = MethodType(__nonzero__, None,
QPyNullVariant)
TypeError: method expected 2 arguments, got 3
python/plugins/GdalTools/tools/CMakeFiles/zzz-GdalTools-2-depend.dir/build.make:117:
recipe for target 'python/plugins/GdalTools/tools/ui_widgetInfo.py' failed
make[2]: *** [python/plugins/GdalTools/tools/ui_widgetInfo.py] Error 1
CMakeFiles/Makefile2:5080: recipe for target
'python/plugins/GdalTools/tools/CMakeFiles/zzz-GdalTools-2-depend.dir/all'
failed
make[1]: ***
[python/plugins/GdalTools/tools/CMakeFiles/zzz-GdalTools-2-depend.dir/all]
Error 2
Makefile:160: recipe for target 'all' failed
make: *** [all] Error 2

The only description that I was able to find was this one:

https://github.com/qgis/QGIS/commit/ae3db0a1bf9504b432e4553b94a56051576c053f

but the proposed fix is already incorporated in the code I have. There is
also a mention of potential conflicts arising from different versions of
python, but I have not been able to figure out a solution.

Anyone expericed this? Any hint will be appreciated,

Thanks.

/H.
_______________________________________________
Qgis-user mailing list
Qgis-user@lists.osgeo.org
List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user

Reply via email to