Hello all:

I'm trying to install the MOLUSCE plugin on Linux Mint 18 (Ubuntu 16.04). I get the following error:
The plugin is broken, Python said:
cannot import name NavigationToolbar2QTAgg

Indeed, in Ubuntu the maplotlib libraries do not have that module. This works:
from matplotlib.backends.backend_qt4agg import NavigationToolbar2QT as NavigationToolbar
(NavigationToolbarQT without the Agg at the end)

I checked on a Windows 7 machine with QGIS 2.18 standalone and the plugin installs fine.

Any ideas how to straighten this out on Ubuntu?

Thanks, Micha
_______________________________________________
Qgis-user mailing list
Qgis-user@lists.osgeo.org
List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user

Reply via email to