Hi, all. I spent last weekend learning to use QGIS, and as a result I
have a fair amount of feedback. On the whole I'm quite impressed,
especially when I want back to check some things in ArcMap afterwards
on Tuesday; but there are also a lot of areas that seem to lack

I took some notes along the way, which have turned into this email
(which it took me all week to get finish writing up...oops!).
But I expect the proper thing to do is to file bugs for all of them
(assuming they are not duplicative) and then start submitting pull
requests on Github to address them, at least where doing so is within
my means. If there's a better path, I hope someone will let me know.
I realize some of these issues may by GDAL or Qt 4.8 or other issues
outside the scope of the QGIS project directly.

I realize this email is way too long for anyone to reasonably go
through. So I look at it more as an exercise for myself to put my
thoughts in order before filing bugs. If someone has a better
approach, please let me know. My goal is to contribute productively
to the project. (I'm not sure that splitting it up into 10 seperate
emails for each category would be productive?)

Also, if this is more appropriate for qgis-developer@, please let me
know that, too.

Since I began last Saturday, I did this against QGIS 2.18.2, using
William Kyngesburye's builds installed via Homebrew. Although I
realize 2.18.3 came out this week. (From a brief glance at the release
notes -- hard to find! -- it doesn't look like any of the changes are
pertinent). I also belatedly realized I was using 2.14 manual, and I
have a bunch of documenation comments, but the few I spot-checked
remain issues in the github repo.

I am not really a GIS person, but I am a data person and a programmer,
albiet not a GUI programmer. I last used ArcMap abortively a few years
ago, and I don't have much experience with Qt. My platform of choice
is Mac OS X. I also have a lot of experience with Adobe InDesign,
which maybe has a similarly complex UI to that of QGIS, although I
think it has a tronger UI history. I also have very occasional
experience with complex UIs like Pro-Engineer, Autocad, etc.

That means I have a number of opinions about how software should work,
and some of the places where QGIS departs from the OS's expectations
are things that bother me. It might well be that the QGIS developers
disagree with me on some points...which is totally fine; my opinions
may be Wrong(tm). Some of these may be Mac-specific, although since
QGIS allows selecting a system UI Style, it's fine to do Mac-specific
things in the Aqua style.

I welcome your feedback and I'm happy to contribute to the project.

My platform was a 13" Retina MacBook Pro (OS X 10.10.5), with its
built-in trackpad (no mouse), which also colors some of my thoughts on
UI issues.

I've tried to sort these into (loose) categories:

LAYERS PANEL                            OTHER WINDOWS
MENUS                                   QUESTIONS
MAP WINDOW TOOLS                        BUGS

*'s are big bullet points, . are smaller issues, and %'s are non-issue
comments along the way.



* Pixelated app-icon. The very first thing I notice is the QGIS
  application icon is pixelated, as seen when switching apps with
  Cmd-TAB. This is kind of off-putting from the start -- first
  impressions are importnat.  I guess the icon is getting replaced
  anyhow, but this is probably just an actual bug/failure to install
  the right icon in the right place. The Finder (e.g. Get Info on the
  app) properly displays a hi-rez icon for QGIS.

* Tool icons don’t show keyboard shortcuts on hover (tooltips). When
  learning any complicated application, it's important to be able learn
  the keyboard shortcuts quickly and easily. One of the best ways is
  the tooltip. But QGIS's tooltips in its toolbars don't show keyboard
  shortcuts (except in the Attirbutes window, see below).

* Tooltips are too slow for beginning users. I don't know if they're
  appropriate for experienced users (tooltips are a horrible UI for
  anything. But unfortunately we don't really have a better one out
  there for mastering a GUI). Clasically under OS X you can adjust
  the tooltip delay by hand for Cocoa applications. E.g.:

     defaults write org.qgis.QGIS2 NSInitialToolTipDelay -int 100

  Unfortunately that doesn't work for QGIS, presumably because it is
  Qt-based. It looks like Qt 5 adds configurable tooltip durations
  but it doesn't sound like there's a good application-independent way
  to configure it.

  I guess that means I'd like a tooltip delay preference in QGIS (in
  the development branch with Qt 5 support), or I suppose a general
  mechanism in Qt for overriding the tooltip delay. But I think
  there's a colorable argument that a complex application like QGIS
  needs a shorter tooltip delay than a simpler application can get
  away with.

* Undo is very limited. For instance, I often found myself creating a
  layer group when I didn't want to, or having it end up in the wrong
  place (inside an existing layer group rather than at the toplevel of
  the layers panel), and wanting to undo it. I think the world's
  acceptance of limited undo has also gotten worse in recent years --
  the prevalance of mobile apps with touchscreen UIs where people
  easily make errors means that everyone expects a fully-featured
  Undo. QGIS needs to do better.

* Keyboard shortcut configuration is broken.

. As a prelude, the first time you open the Configure Shortcuts
  window, it is super-small, and you have to expand it. But windows,
  esp. modal dialogs, should open at the appropriate size by
  default. At least where that size is something that works on all
  reasonably-sized screens, as is the case here.

. At least for the preferred modifier for OS X, namely Cmd (Command),
  the Configure Shortcuts function is plain busted. It will not let me
  assign Cmd-Shift-G to Add Group. Although it does let me assign

. It displays the wrong modifier for OS X. E.g. Add Vector Layer is
  Cmd-Shift-V, but it is displayed as Ctrl-Shift-V.

. Not broken, but it sure would be nice to be able to export a
  shortcut set to a text file so you could search through it in a text
  editor. This feature is pretty handy in Photoshop and InDesign.  At
  first I thought this just a matter of dealing with converting from
  the XML format that is the only choice, but actually the XML
  shortcut set only inclues *changes* from the defaults, not the whole

* Left keyboard arrow inside a hierarchical list (such as in a Layer
  Group in the Layers panel, but many other places) does not move the
  selection up one level of hierarchy to the parent, nor does it close
  the open layer group. It should do one of those things. Is this a Qt issue?

* There apppears to be no indication of which subwindow/pane has the
  keyboard focus.

. Although there is a blue highlight around a currently active widget,
  that's not prominent enough. For instance, there is visual no way to
  tell that the main Map Window has the keyboard focus, other than
  perhaps process of elimination because nothing has a blue highlight;
  although that's not reliable, as the currently selected widget might
  be scrolled out of view in some panel. And also a more prominent
  indicator is required.

. The title bar of the currently active panel should change somehow to
  indicate it is active. And there should be some related mechanism
  for the Map Window.

* There is no no keyboard shortcut to switch between panels, at least
  when the panels are docked.

. After undocking a panel from the main window, keyboard panel
  navigation is...borked. Cmd-` ought to cycle through an
  application's windows, but it half-works. If a floating panel is
  selected, Cmd-` moves focus to the main window. But another Cmd-`
  does not move it back, nor does Cmd-Shift-` (which should cycle in
  the other direction through the ring of all windows).

* The project's filename is not properly displayed in the window's
  title bar using the OS mechanism. That means there is no icon next
  to the filename, and and you cannot Cmd-click on the titlebar to
  open the enclosing folder in the Finder.

* It is too easy to dock panels sometimes. If I start with the Layer
  Styling panel docked on the right, if I try to expand its width to
  the left, I can inadvertently dock it to the top the main window. I
  have not then been able to figure out how to re-dock it to the
  right, where it belongs. I can float it, but that's not the
  same. Had to quit and restart.

* Having multiple vertically stacked widget groups that can have their
  own vertical scrollbars within a single panel is very
  confusing. Especially because you can resize these vertical widget
  groups -- sometimes accidently. It's possible to get a really messed
  up Layer Styling panel because of this. And it is worse beacuse
  there can be multiple apparently active vertical scrollbars in the
  same panel, e.g. the scrollbar for the top/main part of the
  Symbology pane, as well as for the Symbol List beneath "Symbols in
  group". That means the user doesn't know what the trackpad
  scrolling/mouse scroll wheel is going to do -- which one is going to
  scroll? (answer: the one you didn't want). This problem is also
  visible in, e.g. Preferences > System > Environment vars.

* The "Step up" and "Step down" functions (e.g. up/down arrows for
  adjusting the point size of fonts or width of strokes/outlines,
  etc.) are sometimes scaled inadequately.

. There should be an easy way to increase the stepsize. The usual UI
  idiom (sadly not discoverable!) is to shift-click the up/down arrows
  to multiply by 10x. The inverse is to option-click for finer
  control, typically 1/10x but maybe a different factor, or maybe an
  integer unit.

. Perhaps it is the case that the default adjustment quantum is not
  correct. I am unsure. It matters a lot less when shift-click works.

* Numerical adjustment boxes with multiple units should convert
  values when units are changed. For instance, if I have a font
  specified as 13 Points, and I switch the units to Map Units, then it
  should be stay 13 Map Units. It should convert, as appropriate, (for
  map units, of course that dependson the current
  scale/magnification). So also for pixels, millimeters, etc.

. In this US, millimeter are not a common unit for design. It would be
  nice to have points (1/72" of an inch) available as well. Not just
  for fonts, but also for strokes/outlines.

* The default font is Helvetica, which is fine, but for some reason
  QGIS won't show me any subfaces of Helvetica by default. If I switch
  to another font and then switch back to Helvetica, then I am given
  the proper face choices (Light, Regular, Oblique, &c.). Something's
  wrong with the font selection defaults (perhaps in Qt?)

* When I select a new font, the font face defaults to the first face
  alphabetically, which is usually Bold. That is not correct. It
  should default to the default face, e.g. Regular or Roman or Black
  or whatnot.

* When opening a medium-sized QGIS project, I initially get an a
  black-and-white quartered circle cursor, which seems like it's
  intended to be an hourglass, and that lasts for about 3 seconds.
  Then it switches to the OSX rainbow beachball ("spinning wait
  cursor") intermittently for a few seonds, and then QGIS responds.
  Appearence of the beachball means some kind of thread badness, I
  think -- it should only show up when the run loop is blocking
  for too long, and that shouldn't happen, so it's a bug in of itself.

. Also, any wait longer than a second or so probably deserves a
  progress bar.

. I also got confused why I started getting an "Updating Feature
  Counts" progress bar when I opened my project, but later I realized
  this was because I had enabled feature counts on a layer. I think I
  would rather that the feature count be cached rather than
  recalculated every time the project is opened. The cached number
  could be displayed differently (lighter greyer text?) to indicate
  QGIS wasn't confident in it (also, what happens if the shapefile
  changes out from under QGIS while it's running?).

* View > Toogle Full Screen...does not really do what I want. I would
  like a way to make the Map Window consume all of QGIS's screen real
  estate, hiding any currently floating panels and taking the space of
  any docked panels. In the Adobe Creative Suite programs, TAB does
  this. Instead, in QGIS, Toggle FS seems to just allow QGIS to use
  the 24px normally occupied by my menu bar. Sure, sometimes that
  might be handy to do, but not as much as I'd like to be able to see
  the full map without all the panels.

. F11 is bound to View > Toggle full screen, but OS X steals that
  keybinding for an OS function ("Show Desktop"). If it's not going to
  work, it shouldn't appear by default in the menu.

. If you enter fullscreen mode and then Cmd-TAB to another app and go
  back to QGIS and toggle full screen some more, it's possible to
  screw it up. Right now I have QGIS in a state where Toggle FS
  switches between occupying the full screen (including the 24px of
  menu bar) or appearing right below the menu bar. But I can't get
  back to having a main window with window decorations that I can
  resize or move around the screen. Wacky. Restarting fixed it.

* If you undock the Layers panel (and presumably others) and put it in
  the middle of the screen (for some reason), then if you restart
  QGIS, it can occlude the Recent Projects pane, making you think QGIS
  is hung. But it's really waiting for you to do something in the
  Recent Projects pane, it's just that you can't see it. Oops?
  Conclsuion: Recent Projects should be on top of floating panels?

* Recent Projects shows the filename, but cuts the wrong side of the
  dots. If my filename is "2017.01.14 qgis learning.qgs," it shows me
  "2017", cutting off to the left of the first dot. But instead it
  should cut off to the left of the LAST dot.

* With the Aqua UI (MacOS native) selected, the Cancel and OK buttons
  have the text shifted too high by a few pixels. It looks subtly
  bad/wrong.  On OS X 10.10, the system font is Helvetica Neue. Sure
  enough, changing Preferences: General: Font to Helvetica Neue fixes
  the shift. Is this supposed to happen?

. It is a bit annoying I cannot select a font (in Preferences:
  General) until I hit the radio button next to the font
  dropdown. That radio button should autoselect when you click in the
  Font dropdown.

% As of OS X 10.11 and up, the system font changes to San
  Francisco. I'm not sure what kind of default is proper here.  I
  don't have a handy more recent machine, although I could find one if

* Preferences: Icon Size doesn't seem to honor the Cancel/OK button at
  the bottom of the window. If I choose 64px icons and then I hit
  Cancel, they stay 64px.


* Importing layers from Browser Panel

. It seems peculiar that this seems to be the most efficient way to
  import layers. Far more so than using the "recommended" and obvious
  way of Layer > Add Layer (or the toolbar). Those require having to
  think about what kind of layer the file you haven't yet selected is
  going to require, but this doesn't.

. When bringing in multiple layers from the Brower Panel, the
  secondary-click menu is a bit confusing. If I select two layers and
  rightclick, I'm given both "Add Layer" and "Add Selected Layer"
  as options. But if I click "Add Layer," it doesn't add the
  *selected* layers, which is my UI expectation. Instead it adds the
  single layer the mouse happened to be on when I chose it. It would
  be better for "Add Layer" to be greyed out, or to stop having two
  seperate functions and merely display either "Add Layer" or "Add
  Layers" depending on whether one file was selected or more-than-one.

. Drag-and-drop of a layer from the Browser to the Layers panel is
  confusing. The UI doesn't show you where the layer is going to end
  up -- there should be a visual indicator.

. When the Layers panel is undocked, drag-and-drop into it doesn't
  seeem to work. And weird things happen with which items in both the
  Browser Panel and the Layers Panel are selected when you release an
  (unsucessful) drag-and-drop.

* The Add Layer Group button is too hard to "read" -- the
  16px version (default; even when the icon size pref is 24px) on a
  hidpi display just makes the green plus-sign in the corner far too
  small. All that detail in the overlapping layers is nice, but the
  plus sign needs to be a lot larger. I realize there's a desire not
  to confuse it with an "Add Layer" function, but still.

* It is hard to know where the Add Layer Group function will put the
  new group -- it seems to appear at the bottom of the layer list,
  which may be out of view so you don't even know if anything
  happened. So inadverently you might repeat the operation trying to
  see if it worked. Or wondering if the new group appeared inside an
  existing subgroup and hunting for it.

. I tend to think the new group should be added above or below the
  cursor / highlighted group.

. But if it is going to appear at the end, then the group list should
  scroll automaticaly such that it is in view.

* I had trouble finding the icon to delete layers. At first I thought
  there wasn't one. Ultimately I found it...I suppose this means that,
  emperically, I have a similar quibble with Remove Layer/Group as
  with Add. Although I think I may have been confused by the fact that
  it is Add and Remove rather than Add and Delete. And also that it's
  a bit odd to combine Remove Group and Remove Layer. Not sure. I
  think I would also expect a Trashcan icon rather than a red minus

* If I try to Remove a just-added empty group, QGIS gives me a warning
  dialog box. That seems wrong -- empty groups should remove without
  warning, otherwise it contributes to desensitizing the user to
  warnings, which is bad.

* Which leads to...I inadvertently removed the wrong layer, and
  clicked OK and it was gone. Edit > Undo would not recover from this
  situation. Very unfortunate.

* Reordering layers doesn’t work well in the GUI.

. The mouse precision required to insert an item between two layer
  groups is way too fine. There should be more pixels available so you
  don't have to nail a 1px high sweet-spot.

. The visual indication of where a dragged layer will fall is too
  subtle. It should be several pixels thicker.

. There should be buttons in the Layers panel to move a layer Up and

* It is unfortunate that the icons for Expand/Collapse layers
  are Up and Down arrows. This leads to the confusing impression that
  they will move layers up and down the layer listing, but they don't.
  Since the hierarchical list widget shows depth with horizontal
  spacing, expand/contract are better done with horizontal arrows (if
  you're going to use arrows at all, which might not be best).

* If I have styled a layer by Category, and then I expand the
  disclosure triangle in the Layers panel to show those categories,
  and then click on the layer and select it: then if I use the
  keyboard (or mouse, but that's more confusing) to go up/down by
  category with the arrow keys, the currently selected category
  doesn't highlight. But it is clearly selected -- hitting spacebar
  will toggle its visibility. So something is wrong here.

* If I use Remove Layer/Group, I get warnings about "Legend Entries."
  Why/how is a layer a synonym for a legend entry? Is that just an

* I would like the ability to select a group of layers and then sort
  them (alphabetically).

* I'm surprised I cannot Select All Layers somehow, such that I can
  do things like Show Feature Count on all of them. I'd expect it in
  the context menu or maybe the menubar Layer menu... I realize
  shift-Click works.

* Apparently double-clicking on a layer can be configured to do
  different things (Open Layer Properties, Open attribute table; Open
  Layer Styling Dock)? This is a bit strange. It seems that it should
  do one thing only, and there shouldn't be a preference to change it
  so radically.

  But in any event, all 3 are useful things to do, and there should be
  an easy and fast way to them. The obvious choice is
  modifiers. Cmd/Ctrl-click for the Attribute table, and
  Option/Alt-click for the layer styling dock.

  It's especially important to have a good way to open the Attributes
  panel beacuse on a Mac hitting F6 is mildly annoying --
  effectively it's Fn-F6, unless you have decided to forgo the OS's
  media key functions (maybe appropriate if you spend a lot of time in
  apps that are heavy on function keys, which QGIS is not?).


* Switching a layer's symbology from fill to stroke seemed too
  hard. Maybe it's too much time in Adobe Land, it seems like a big
  production to remove a fill and add a stroke.

. I found the labelling of stroke as "Outline" to be
  non-intuitive. This may be my Adobe background speaking, but I think
  it'd be a lot more clear as Stroke.

. In the layer styling panel, you have to drill down to Simple Fill in
  order to get to these controls. This is nonobvious, beacuse the
  color is shown at the Fill level. It's also nonobvious because Fill
  and Stroke are pararalel concepts in most UIs. But in QGIS, Outline is
  subsidiary to Fill.

. The fact that "Outline" and "Outline width" are separated by 3 other
  controls seems peculiar, esp. when some of those controls have to do
  with Fill but not Outline. Conceptually related controls should be

. I really miss the "Swap Fill and Stroke" function in Adobe apps -- a
  little 45-degree curvy arrow next to the Fill and Stroke
  swatches. In Illustator, this is bound to a single keypress (X). In
  QGIS you have to swap them by hand.

* In the Labelling and Symbology panels, if most of the widgets are
  inactive in the absence of a selected column ("Label with"), then
  all of those widgets should be dispayed inactively, e.g. greyed out.

* The column dropdowns in Layer Styling are hard to use, for Fitt's
  Law reasons. https://en.wikipedia.org/wiki/Fitts's_law
  Most of the time, I think, people want to select an existing column
  from a list, rather than to type one in from scratch.  But of a
  328px wide "Column" widget, 310px are for the text field, and that
  leaves 18 px for the button. But you want the large button to be the
  thing people use most often (per Fitt's Law).

. Ideally, clicking anywhere in the field should give you the
  dropdown, and then if you start typing, you can override the list
  with your own choice. This certainly makes sense when the column
  textbox is blank. When it's non-blank (a column is selected), I
  think this is also a reasonable way to go. However I don't have a UI
  precedent to offer for it.

* In the Labelling pane, Rendering tab, the GUI looks very strange if
  you collapse the 3 disclosure triangles (Label optons, Feature
  options, Obstacles). Two float at the top and one at the very
  It's not clear why there should be disclosure triangles at all in
  this UI, given the presence of a vertical scroll bar.

* In both the Layer Styling: Labelling pane and the Layer Properties
  window, the tabs have headings at the top like Text, Formatting,
  Buffer, etc. Those headings are in the same typeface as the widget
  beneath them, so they don't afford  as headings. They should be in
  boldface, or separated, or something to indicate the hierarchy.

* The overlap between Layer Properties and Layer Styling can be
  extremely confusing. The two UIs are similar enough that it's easy
  to get confused, and then easy to get frustrated when you can't find
  something that are sure was there. E.g. AutoApply is in the styling
  but not the properties. And the UIs widgets are slightly different.
  What is the reason for this inconsistency and can it be remedied?


* Layer > Labelling feels very weird. It pops up the Layer Styling
  panel, but its not a panel control, like View > Panels > Layer

. If you already have the the Layer Styling panel open on the Labels
  pane, it appears to do nothing. This is confusing. (Should it be
  greyed out?)

. It feels like it should have a checkmark next to it to indicate the
  panel is open. Although it's not clear to my why this function even
  exists. Where are the parallel Layer > Symbology or Layer > History
  menu items?

* Why are some things Create Layer and others Add Layer? It seems like
  the distinction is not very clear. Esp. because Add Delimited Text
  Layer produces a dialog named "Create a Layer from a Delimited Text

* I am troubled by the decision path for the Add Layer menu options
  (and toolbar icons). I have to think about what kind of file I want
  to add before I navigate to that file, which seems wrong. And QGIS
  clearly knows how to figure out what to do based on the file type --
  it works from the Browser Panel, and works if I drag and drop a
  shapefile on the app. So why isn't there a simple Open File or Add
  Layer dialog that lets me choose any filetype and adds it as a layer
  as-appopriate? The specialized non-file interfaces can remain, or
  they could combined into a fancy dialog box. But for dealing with
  local files, the paradigm seems "off."

* Add Vector Layer's workflow is not keyboard-friendly. If I want to
  open a shapefile, after the initial Cmd-shift-V, I have to hit TAB
  TAB TAB RET to get to Browse to open an NSOpenPanel (OSX's file open
  dialog), and once I've selected a file there, the Add Vector Layer
  window loses focus. So I actually have to click in the window to
  make it active before I can select OK.

. It also has no title bar in its window; and it's missing a bunch of
  window decorations, too.

* Settings > Style Manager also pops up a window with no title bar or
  upper window decorations. Weird...

* In Style Manager, if you double click a marker icon, you get a very
  small 407x279px window. But the window should be much larger, like
  320x630px at a minimum, to display all the widgets. In the initial
  small size, it's not completely obvious there are offscreen widgets,
  so it just feels confusing. You can miss Units, Transparency, etc.

* Hierarchical menus are bad. They can be a necessary evil in a
  complex application like QGIS, but their use should be minimized
  where possible. Because of Fitt's Law, it is challenging for humans
  to mouse into hierarchical menus, and they make for a bad user

. Everything that is in View > Panels should instead just be in the
  top-level Window menu. This is both easier to access, and also where
  Mac users expect to find panel controls. See

. I'm less sure about View > Toolbars, but my off-the-cuff would be to
  put them in the Window menu as well. InDesign does that, but it
  really only has 3 toolbars vs. QGIS's 12, so it's not a direct

* There is no Project > Revert function. Because of the limited Undo
  functionality, it should be easy to go back to the last saved
  version. Of course you can Project > Open, but a Revert function
  would be nice.

* QGIS wants to always have a project open, which feels
  weird. Especially because at startup, it has no project open, and
  displays the Recent Projects window instead of the Map Window.  So
  it feels like you ought to be able to get back to that state by
  closing the current project, i.e. a QGIS > Close command. But that
  doesn't exist. Why not?

. I also tend to think that the app should not exit instantly when you
  click the red "close window" decoration in its main window. I
  realize it's not a document window, but it feels like one. So at
  least a dialog "Do you want to exit QGIS?" would seem meritted.

. By comparison, most Mac apps let you close their document windows
  and leave you only with a menu bar. In InDesign's Application Frame
  mode, which is kind of like QGIS's model, you can X away the
  Application Frame, and then you have only the menu bar. And ID will
  bring it back if you open a document.


* Identify Results goes out-of-window. When I select Identify Features
  and click on a feature, I get a a 565px-wide Identify Results
  window, with about 700px worth of content. The "Feature" column
  takes up all 565px initially (more), so unless you happen to notice
  the [somewhat subtle, becuase of OS X Aqua] horizontal scrollbar at
  the bottom, it's easy to miss that QGIS even has a "Value" column,
  that just happens to be scrolled out of view. The default column
  width of Feature should be small enough that you can see there is a
  Value column. And ideally both should be somewhat balanced so they
  can be both read. 50/50%?

. The Identify Results panel has controls at the bottom of it that
  affect the behavior of the Identify Features tool! This is
  definitely unexpected -- it is a Results panel, not a Control
  panel. One would normally expect such controls to be in the toolbar,
  (Photoshop does this with many tools, popping up tool-specific
  application bar). It's especially strange because these controls,
  which are not initially visible, affect the use of a tool which is

. Perhaps rename Identify Results to Identify? Better to relocate the
  controls to a toolbar? Or as a transition, do both?

* The zoom tool icon design is...kinda clunky. I think it's mostly
  because it's more like a diamond with rounded off corner rather than
  a circle, like in most apps. Can we change it?

. The difference in appearance between the toolbar icon and the canvas
  icon that selects it is...dissonant. They ought to be as similar as

. Normally I expect option-clicking the zoom in tool to give me zoom
  out functionality, and vice-versa. Doesn't seem to happen here.

* The hand tool does not behave like the hand tool does in most other
  applications. In most apps, dragging with hand tool pans the canvas
  in the window, and a single click of the hand tool does nothing

. But in QGIS, a single click of the hand tool recenters the map on
  the spot of the click. I realize that ArcMap does this too, but I
  definitely find it weird and off-putting, and it's not what the hand
  tool does in the software I'm used to. (UI guideline: if two things
  look the same but have subtly different characteristics, it will
  annoy users.)

. I guess I would like a way to turn this feature off (or relegate it
  to option-click or something). Although I'm sure there are ArcGIS
  (and now QGIS) users who depend on it, so it probably has to be on
  by default?

* Zoom to Full / Zoom to Selection sometimes seem not work. They
  appear to do nothing. Restarting QGIS fixes this. But when it get
  stuck like this, the map window just remains blank, live I've zoomed
  all the way in or out beyond the point of reason. (QGIS is not quite
  like The Powers of Ten, alas.)

. On the other hand, usually I can select the Zoom tool from the
  toolbar and zoom in and get a reasonable view. I don't understand
  what triggers this.

* On a trackpad, two-finger touch normally scrolls/pans a window.
  In QGIS, it zooms in and out. That's probably appropriate for a
  mouse with a scroll wheel, but it works very poorly on a trackpad.
  For one thing, the zoom is far too fast, and there isn't much

. I'd tend to think for a trackpad, 2-fingers should pan the map
  window and a modifier (Option, etc.) would zoom. Adobe products use
  this model. For Microsoft products, the modifier is a pair: Cmd+Control.


* The toggle editing mode (hereafter TEM) icon misuses the "greyed
  out"/disabled convention, and this misuse is terribly confusing to
  users. A greyed out icon is supposed to mean it is UNCLICKABLE. Not
  that everything else is unclickable until you click this one icon. I
  think the proper icon here is a locked or unlocked padlock (and
  never grey). The other icons properly have an active/inactive state
  that goes with the toggle editing mode icon.

. Also I find it disconcerting that a lot of my screen changes when I
  click the TEM icon. The addition of the Column / Expression / Update
  All/ Update Selected bar beneath the toolbar when TEM is clicked
  seems wrong. I suspect that bar should always be present, or
  otherwise toggle-able. Or perhaps it could have a tri-state: On,
  Off, or On-while-editible (today's behavior).

. The TEM button seems to be global rather than window-specific.
  E.g. clicking TEM in the attribute window (de)activates the TEM icon
  in the Digitizing Toolbar, which is on by deafult. This is
  nonintuitive and causes flashing in parts of the UI where your eyes
  are not focused, which is distracting/annoying. I think it also
  violates expectations.

. Clicking TEM in the attributes window also causes the main map
  window to redraw. Again, annoying flashing, and also it may have
  performance implicatinos.

* Tooltips have keyboard shortcuts here! This is wonderful! And yet it
  underscores their lack elsewhere.

* The Attributes Window should have its name in the title bar, as all
  windows should.

* When opening a table with just a few columns (e.g. 4), they are often very
  small widths, truncating the display of data. Where there is excess
  space, QGIS should autofit the colum widths in this window.


* Query Builder (Cmd-F, Filter on a layer): Has a bright blue OK
  button in the bottom-right corner, indicating that it is the default
  function when you hit Return [or maaaaaybe Enter, aka
  Fn-Return]. But pressing either of those thigns doesn't
  work. Probably it needs:

. Fn-Return should click the OK button.

. Most user won't know that, so the OK button should have a tooltip
  making that clear.

. As a last resort, the blue could be turned off, but that is a bad
  workaround, not a solution.

. Cmd-. should always activate the Cancel button. It does nothing
  here. Escape should work, too.

. The other buttons (Help, Test, Clear as well as Sample and All)
  should probably have keybindings too. This is easy to do without
  conflict since it's a modal dialog.

. As an aside, this is an awesome window. It works great! And the Test
  function is super-useful.

. I wonder if the Help wouldn't better off as an adjunct panel
  (sidebar?) that slides out to the right of the Query Builder window,
  rather than a seperate window itself. I think that would make it a
  bit easier to use.

* View > Decorations > North Arrow. I think the most common
  adjustments for the arrow, if done visually with the slider, are to
  move it +/- 180 degrees from North. But the slider goes from 0-360
  and starts at zero ,so to make a small change in the negative
  direction, you have to slide all the way to 354 or
  whatnot. Shouldn't this slider go from -180 to +180 with repect to
  North and start in the middle?

. It is wrong for the angle slider to work when the Set Direction
  Automatically checkbox is checked. Either sliding the slider should
  turn off the checkbox, or the slider should be disabled/grey when
  the box is checked

* Preferences: Colors has a single sub-pane, Standard Colors. Yet
  there is a disclosure triangle. This is wrong, there shoudn't be a
  disclosure triangle for one group of items.

. Also, there is a field called Label for each color, but it is not
  filled in. Shouldn't these standard colors also have Standard Names
  (Standard Labels)?

* In Preferences, there seem to be some border widgets missing. When
  General, the first pane is selected, the top of the window's
  continuous gray feels like it should be the border of the entire
  window, which is present on 2-and-a-fraction sides. (All top, all
  right, most of bottom). But then when you switch to another pane,
  you realize it is the highlighting of the General button that was
  causing the continous gray across the top, which is dissonant now.
  So I think the whole window needs an interior border?

* Settings > Style Manager allows me to edit symbols, but not to copy
  or duplicate existing symbols. This seems peculiar -- I want to test
  out changes without destroying what I have already.

* QGIS > About QGIS has lots of version stuff information, like the
  current version and What’s New, but no way to check for a newer
  version? So if you start QGIS and get a note about a newer version
  but dismiss it, looking in the About QGIS box is a likely place to
  find more about what you missed. Users expect a certain degree of a
  parallelism between the Splash and About windows, nd the splash
  window does provide new version checking.
  (I realize it is in Help > Check QGIS Version)

* Plugins > Manage and Install: the one plugin I looked at was the
  "eastcustomlabeling" plugin. But when I followed the links to it
  from the Plugins dialog, I get 404 Not Found.
  Not sure if this is a larger issue or just this plugin?

* There is a lot that I find a bit odd about the Print Composer and
  it's UI paradigm, but some small items:

. Cmd-shift-V does something very different in the Print Composer --
  Paste in Place instead of Add Vector Layer. I can kind of see why
  this might be happening, but the idea of having totally different
  keybindings in differnt windows of the same application seems pretty
  novel. And novelty in UI design results in confusion more often than

. The first and most prominent button in the Print Composer window is
  Save Project. That seems strange -- both because (a) Save Project
  doesn't seem like it belongs in the composer at all (since it is
  global), esp. as the main window's Save Project button is still
  visible in the default composer window size; and (b) most people
  probably save with Cmd-S  on the keyboard. Isn't there a more
  important button that could be in that special position, the "100%
  corner" as it were?

. Project > New Composer Window: gives me a dropdown textbox hybrid
  widget for the new composer name. This seems odd -- I would pretty
  much never want to select the name of a previous composer window as
  the basis for my new one, would I? If you want a list of existing
  composers for some reason, give me a list widget above the textbox
  for the new composer.

* The Layer Ordering panel is hard to use if there is more than one
  screen's worth of layers, and you want to move a layer fro mthe far
  bottom to the far top. It should have Send to Front, Send to Back
  functions for the selected layer, either as icon buttons,
  secondary-click menu options, or both. (Maybe those functions should
  appear in the regular Layers panel, too?)


% One of the first things I did was try to import some non-spatial
  data from an Excel spreadsheet into QGIS to use in conjunction with
  some shapefiles. This ended up being a lot more difficult than
  expected. I expected I would initially use a TSV (or CSV) file to
  bring it in.

% Because of a longstanding bug/wart, Excel for Mac (at least my
  version) exports CSV files with CR (Ctrl-M, \015) as a line
  delimeter, rather than CR or CRLF. This was the classic Macintosh
  line delimeter back in the days of yore, which somehow survived the
  transition to OS X, but only in some rare cases. The result is if
  you save as Tab Delimited Text, you get a TSV with Ctrl-M.
  (There are some workarounds, of course...)

* Add Delmited Text Layer will not properly recognize a CR-delimited
  TSV. This is annoying. It should, because of the history of such
  files under OS X, and because it's still unfortunately way too easy
  to create them.

. I imagine that this is an ogr2ogr issue?

% Having gotten past that, I then tried to create a virtual layer from
  my layer, either for filtering or joining, I can't recall.

* Add Virtual Layer's Query Pane has a huuuuuge tooltip. The text here
  is very helpful, except you cannot see it while you are typing,
  because it is a tooltip. Classic failure of "instructions at point
  of need." See above suggestion of sidebar/sidecar Help window in the
  Query Builder window. This has a lot in common with it.

% After apparently satisfying the Query Pane's constraints and hitting
  OK, then:

* I got a multi-line error displayed at the top of the Map Window that
  was hard to read. I couldn't figure out how to easily scroll the
  error, and it seemed very hard to read. Something about the layer
  not being valid. 

* Maybe worse, the error disappeared before I could finish reading
  it. A bright red error message suggests something is really
  wrong. It shouldn't just time out. In fact, pretty much no error
  messages should ever time out while the user isn't actually doing
  soemthing (clicking or typing).

* Back in the Query Pane, there's no handy enumeration of fields like
  there is in the Query Builder (Cmd-F). That small UI dissonance is
  disappointing. What's good for the goose is good for the gander?

. I realize there's some kind of autocompletion of field names, and
  also that the Query Pane has to deal with multiple tables and their
  fields. But that is a reason why autocomplete is not adequate, and
  the information on field should be available in a more structured
  navigable way, like a hiearchical list.

. This is doubly true because Query Pane is a modal dialog, so you
  can't go elsewhere and look stuff up.

% In my example, my imported data came with an Address field, and I
  wanted to join it against spatial data also with an Address
  field. Unfortunately the imported data had the city name in the
  Address field, and the spatial data did not. (All rows were in the
  same city.)

% So I figured that was no problem, I would just use a Calculated
  Field with a regular expression to remove the city name. Easy-peasy.

* After opening the Field Calculator feature in the Attribute Window,
  and creating my field ("shortaddr"), I couldn't figure out how to
  see the definition of the field I'd created. If there's a way to add
  a calculated field in the Attribute Window, there should be a way to
  edit it.

. Ultimately I figured out that I could edit it in Layer Properties:
  Fields. But that's not enough.

* Then with my calculated field, I was all set to use it in the query
  in my Virtual Layer. But...apparently you cannot use calculated
  fields in Virtual Layers? Worse, you don't even get a sensical error
  message. It just basically doesn't work :( I tried to a join like:

    select ap.geometry, ap.address from ADDRESS_AddressPoints ap, sbu  where 

  No joy. Not enough debugging information.

* As a result, I exported the layer with the virtual field to a
  shapefile, and then reimported that shapefile. Essentially
  un-virtualizing my virtual field. Surely there was a better way?

% Next, I tried to do a Join in Layer Properties: Join to hook up my
  two layers.

. I think ArcMap has an easily findable Join function -- something
  like the equivalent of Layer > Join. But in QGIS it is buried inside
  Layer Properties. Why isn't it more of a first-class function? Joins
  are powerful and important. That should be true in the UI too.

% It made sense to me to join my small (100-row) imported attribute
  table (SBU) against my big spatial table (AddressPoints).

* This doesn't work. The result of joining an attribute table against
  a spatial table is an attribute table with no spatial data. To get
  spatial data in the result, you have to start with the spatial table
  and join it against the attribute table. This seems wrong.

% It also left me with thousands of rows I didn't care about or want.

. There doesn't seem to be a concept like INNER JOIN vs. LEFT JOIN
  vs. RIGHT JOINT etc. in the Join function. Why not? It seems
  especially common that you might want to throw away the rows where a
  join was not actually successful.

* Then I tried to filter my joined spatial layer. I got a dialog
  offering to make it Virtual Layer so that I could subset filter
  it. Unfortunately this didn't seem to work, but my notes don't
  accurately reflect what went wrong, and I can't reproduce it
  now. Sorry :(

* But as a workaround, I exported the layer with the join to a
  shapefile (sound familiar), and then reimported that
  shapefile. Essentially statically duipicating my join. Fortunately
  my dataset was small so this wasn't a big deal. Then I could
  filter my table.

% In my related research, I found documentation "on the Internet"
  indicating that when importing CSV files, it might be important to
  specify the field types, and that ogr2ogr introduces something
  called CSVT sidecar files for this. E.g.

  (This seems totally nonstandard and not used by any other
  CSV-reading software, including "csvkit," nominally the standard).

* But QGIS has such a *nice* UI for importing CSV files, it seems
  bizarre that it does not give you a UI to specify the field types
  and manipulate a CSVT sidecar file. #wishlist

* Also, none of the sparse documentation on CSVT files seems to point
  out that ogr2ogr has support for creating a CSVT file on its own. It
  seems like a much better idea to edit the file it creates rather
  than trying to create it from whole cloth, especially for
  inexperienced users.

  The creation incanation is a bit ugly, though. (Who puts a
  destination in front of a source in a command-line tool? What is
  this, Intel assembler?) For instance:

pb3:Programs jhawk$ ./ogr2ogr -f CSV -lco CREATE_CSVT=YES  /tmp/2 /tmp/1.tsv
pb3:Programs jhawk$ ls -l /tmp/2
total 40
-rw-r--r--  1 jhawk  wheel  16257 Jan 14 23:12 1.csv
-rw-r--r--  1 jhawk  wheel     63 Jan 14 23:12 1.csvt

.  But it definitely seems workable for the QGIS GUI to leverage this support.

% Next, I wanted to import some data from my local MySQL server. But

* QGIS doesn't seem to have built-in MySQL support, even though the
  documentation suggsested otherwise?

. I corresponded with William Kyngesburye about this and he clarified
  that this was a licensing issue (GPL virus issues), but I should be
  able to build the GDAL plugin. Unfortunately while the plugin seemed
  to build cleanly and get autoloaded by GDAL, it doesn't actually

pb3:doc jhawk$
  /Library/Frameworks/GDAL.framework/Versions/2.1/Programs/ogrinfo --debug ON 
MySQL:Voting voters | head
GDAL: Auto register /Library/Application
Support/GDAL/2.1/PlugIns/ogr_MySQL.dylib using RegisterOGRMySQL.
GDAL: Driver MySQL that defines GDAL_DMD_OPENOPTIONLIST must also implement
Identify(), so that it can be used
Unable to open datasource `MySQL:Voting' with the following drivers.
  -> MySQL

  I'm not sure what's going on here, maybe I need to rebuild all of
  Certainly it looks like the pfnIdentify field gets set:

ogrmysqldriver.cpp:187:    poDriver->pfnIdentify = OGRMySQLDriverIdentify;

  and that's what's being complained about in gcore/gdaldrivermanager.cpp:

442     if( poDriver->GetMetadataItem( GDAL_DMD_OPENOPTIONLIST ) != NULL &&
443         poDriver->pfnIdentify == NULL &&
444         !STARTS_WITH_CI(poDriver->GetDescription(), "Interlis") )
445     {
446         CPLDebug("GDAL", "Driver %s that defines GDAL_DMD_OPENOPTIONLIST 
must also "
447                  "implement Identify(), so that it can be used",
448                  poDriver->GetDescription() );
449     }

* I'm a little less optimistic that even if this plugin worked, I
  would magically see "Add MySQL Layer" next to "Add PostGIS
  Layers..." in the QGIS UI. But I guess we'll bringe that gap when
  we come to it.

% Having got my data mostly displayed as desired, I wanted to improve
  the display of labels. The obvious thing to do was to reposition my
  labels so they were outside of their polygon shapes and connect them
  to the polygon shapes with an arrow or line -- what ArcGIS calls a
  Line Callout.

* QGIS doesn't have native support for line callouts. It seems like a
  serious omission. It looks like there are a number of really awkward
  workarounds involving creating spatial fields (lines, polygons) in
  the shape of the line callout, and then plotting layers with those.
  That seems...really convoluted and confusing and not user friendly.
  I also found some discussion of the EasyCustomLabelling plugin for
  this, but it appeared trickier to use than I was up for at the time.
  has some instructions.

% On the other hand, on Tuesday I went back and tried to do this in
  ArcMap and I couldn't make line callouts work there either. Although
  ArcMap has a much better UI for them, it's still -- well...


* QGIS logs to Console.app with some regularity:

1/16/17 19:41:52.779 QGIS[29578]: WARNING: The Gestalt selector 
gestaltSystemVersion is returning 10.9.5 instead of 10.10.5. Use 
NSProcessInfo's operatingSystemVersion property to get correct system version 
Call location:
1/16/17 19:41:52.779 QGIS[29578]: 0   CarbonCore                          
0x00007fff8bf042b7 ___Gestalt_SystemVersion_block_invoke + 113
1/16/17 19:41:52.779 QGIS[29578]: 1   libdispatch.dylib                   
0x00007fff8946ae73 _dispatch_client_callout + 8
1/16/17 19:41:52.780 QGIS[29578]: 2   libdispatch.dylib                   
0x00007fff8946ad86 dispatch_once_f + 117
1/16/17 19:41:52.780 QGIS[29578]: 3   CarbonCore                          
0x00007fff8be8d456 _Gestalt_SystemVersion + 987
1/16/17 19:41:52.780 QGIS[29578]: 4   CarbonCore                          
0x00007fff8be8c6e3 Gestalt + 144
1/16/17 19:41:52.780 QGIS[29578]: 5   QtCore                              
0x0000000108fbbc16 _Z41__static_initialization_and_destruction_0ii + 38
1/16/17 19:41:52.780 QGIS[29578]: 6   ???                                 
0x00007fff6e66bd4b 0x0 + 140735045614923

  You're not supposed to call gestaltSystemVersion() anymore, for many
  years. Looks like it's Qt's fault though?


* Where the are the QGIS 2.18.3 release notes? They are not easy to
  find from the website. It's easy to get to
  but that doesn't cover the "dot" releases. Other links take you to
  which is not so helpful, at least not directly.
  Is there nothing more user-friednly than the ChangeLog? If not, at least
  someting should link to the ChangeLog:

% After I drafted the outline that led to many of the issues in this
  email, I figured I had best go through the QGIS documentation to see
  if I was missing anything totally obvious, and to give it a similar
  level of review. I think my patience for doing so fell off
  exponentially after the first 100 pages, however. And this is
  against the QGIS 2.14 PDF (sorry).

* CRS on first reference. On p.32 is the first time it talks about
  a CRS, but never explains it is a reference system. Acronyms should
  be expanded on first reference (and possibly more than that in a
  manual prone to random-access use.)

* Apple's OS is properly "Mac OS X" shortened to "OS X" not
  "OSX". (But I guess they're trying to rebrand as macOS). Docs
  should be consistent and use "OS X" everywhere, not "OSX" sometimes.

* The use of the X symbol for |osx| is not a good choice, I fear.
  It's nonstandard, it's doesn't trigger "Mac" in most people's minds.
  And worse, it does seem extremely reminscent of the X windows X.
  Probably that doesn't confuse Linux people who are tied to their
  penguin, but us old-timey non-Linux Unix/X11 people kind of cringe.
  Compare with https://www.x.org/wiki/logo.png
  I think a better symbol would be Apple's apple logo
  I'm sure that'd be fair use, also...

* I'm probaly being hypersensitive, but I found this text in
  preamble/conventions.rst to be, well, kinda offensive:

Larger amounts of text may be formatted as a list:

|nix| Do this
|win| Do that
|osx| Do something else

  It can be read to imply that everybody should use Linux ("Do this")
  or Windows ("Do that") but not MacOS ("Do someting else"). I realize
  it wasn't meant that way,  but it should probably be reworded ("Or,
  do this.")

* Section 8.4 refers to the eyedropper tool as a "color picker". This
  is confusing and incorrect. A "color picker" is a complex GUI widget
  that lets you choose any color using sliders and number boxes, etc.

  It is not a tool that lets you pick up a single color from a point
  on the canvas. That's usually called an eyedropper -- which is what
  the icon is.

* Section 8.5 Blending modes doesn't put "soft light" in boldface like
  the others.

* Section 8.7 Measuring doesn't expand UTM (Univeral Transverse
  Mercator) on first reference. And the expansion probably doesn't
  help most people, it probably needs a gloss?

* Through the manual, settings are accessed via "Settings". But under
  OS X, you get there with QGIS > Preferences...

. And the Title Bar of the Preferences window identifies it as
  "Options." As if were weren't confused already!

. If this is platform-specific there should be a note about it. Maybe
  a macro. I guess there is a note in 7.1.14, but I didn't find it
  while reading.

* Ctrl-$foo under Win/Linux is Cmd-$foo under OS X. The manual should
  acknowledge this somewhere, though maybe not everytime. (But maybe
  it should everytime? Because Macs do have Ctrl keys and they are
  available but do something slightly different. So...)

* Sec. 4.1, View Data, talks about WMS and WFS without expanding or
  explaining them.

. Maybe this is an unfair criticism because it does the same for OGR
  and ESRI, as well as SDTS and JPEG. But none of those bother me?

* Sec. 12.1, s/driver/drivers/: "You should note also that some driver
  doesn’t support"

* Sec 12.1.5 Importing Data into PostgreSQL assumes you know where
  ogr2ogr is installed. But in the default binary installation under
  MacOS, I don't think that's a good assumption -- it gets installed
  as /Library/Frameworks/GDAL.framework/Programs/ogr2ogr
  and I don't think it's normal for /Library/Frameworks/anything to
  end up in users PATHs. It's not as if the installation added a file
  to /etc/paths.d.

. I think arguably there should be some a symlink from /usr/local/gdal
  to /Library/Frameworks/GDAL.frameworks, or something. Or perhaps,
  better yet, a symlink farm from /usr/local/bin/ to all the
  individual programs? Not sure. I guess this is a KyngChaos issue
  more than anything else?

. Similarly, I previously had homebrew install the gdal package (as
  distinct from the gdal-framework homebrew cask). That leaves me with
  multiple ogr2ogr's on my system:

pb3:~ jhawk$ locate ogr2ogr|grep /ogr2ogr$
pb3:~ jhawk$ mdfind -name ogr2ogr | grep /ogr2ogr$
pb3:~ jhawk$

* The example ogr2ogr usage passes a password on the
  command-line. That's widely recognized as an extremely poor security practice:

ogr2ogr -f "PostgreSQL" PG:"dbname=postgis host=myhost.de user=postgres
password=topsecret" alaska.shp

. I don't think using a password of "topsecret" as an ironic
  acknowledgement that this is a bad idea is an effective mitigation
  of the problem.

* It seems like there is something consistently wrong with the figure
  crossreferencing code throughout the document. For instances, we
  often see text like "The Feature filtering dialog of the attribute
  table provides the following functionalities (see
  figure_composer_table_4):", but then the figure underneath is
  labelled "Figure 19.33: Attribute table Feature filtering Dialog."

. It seems like "figure_composer_table_4" is an internal label that
  should not be shown to the user.

. I'm not sure if it should be expanded as "(see Figure 19.33)" or
  more completely as "(See Figure 19.33: Attribute table Feature
  filtering Dialog)." Probably the latter?

* "map units" are never explained. The sole reference to them is in
  12.2.2 but it's not really sufficient. I found the meaning
  of map units to be confusing as I started to learn QGIS, and would
  have appreciated a clear explanation of it in the manual.

* 12.3.1: s/where/were/: "QGIS treats the resulting subset acts as if
  it where the entire layer."

* 12.3.2: "2.5 D" is used without defining it? I think it's a concept
  worthy of a few words.

. Also, in the shapefile context, the docs say “2.5D”? Since I more
  commonly see "3D" or "3-D" than I do "3 D," I would tend to think
  that "2.5D" is correct and the usage should be made consistent?
  The AHD says 3D or 3-D: https://ahdictionary.com/word/search.html?q=3d
  M-W says 3-D: https://www.merriam-webster.com/dictionary/3d

* Figure 12.26: In the 2 images on that figure, it would sure help to highlight
  visually the differences between them.

* Grammar, p.109: "Overlapping symbols will simply obfuscate to other
  below. Besides, similar symbols won’t “merge” with each other.”

* Grammar, p.113: "allows to set a layer as just an obstacle"

* Formating, p.142: Fix the column width to avoid hyphenating azimuth().

* Section 12.4: Expressions fails to mention this is SQL[-derived]
  syntax. That’d be helpful for people to know.

* Section 12.6: In formal written English, "it" is not an appropriate
  pronoun to use for a person: “The last person to save its edits
  wins.” However, it's true that English doesn't have standardized
  solutions for gender-neutral pronouns, but "it" is a bad solution.

. The usual solution (not wonderful, but better) is to use the plural
  pronoun ("their edits"); Or recast the sentence: "The last person
  who saves an edit wins."

* Section 14.2, p.207: The "Set group WMS data" screenshot is Huge,
  and has no Figure number.

* Section 14.2.3: "sudo su" incantation is basically...something you
  should never type. It tells the sudo to run su, but sudo has that
  functionality built in. Normally the correct way to get a shell
  via sudo is "sudo -s", although in some cases "sudo -i" might be
  more appropriate, depending on whether you want to execute root's
  dotfiles.  In this case sudo -s is correct. See

* Chapter 17: What the heck is GRASS? Apparently GRASS intergrations
  integrate GRASS database? A gloss would help.

* Chapter 19: the Print Composer. I am confused why this chapter comes
  so late in the book, after estoteric scripting stuff? I think most
  QGIS users want to print (or output to PDF), but far fewer are going
  to tackle batch processing, GRASS, etc. I'd think printing should
  come as soon after vector and raster data as reasonble (maybe, for
  parallelism, it has to come after OGC and GPS data too? But I don't
  think so...)

* Sec. 19.1.3, p.304: The Zoom Out icon is used for Zoom In.

* Sec. 20.13: It would be nice to define TIN and IDW before they are
  used. The definitinos are not far away (3 paragraphs down), but by
  page 379 of the manual, you are in serious danger of losing the
  reader. And they are at a deeper level of hierarhcy. I definitely
  got very tired and confused at this point.


* It appears from the manual in Section 16.1.2 that a Master Password
  -protected authentication system will just erase your authentication
  database after 3 wrong attempts if you just hit RETURN, by DEFAULT?
  That seems horribly unfriendly to the user, for no gain in security.

. Removing the default OK button would be  start...

. But still, that seems like a great way to lose data?

* Why does QGIS use Transparency sliders instead of Opacity sliders?
  Isn't Opacity much more common in graphics software?

* How come the 2.5 D Renderer doesn’t show up in my layer styling
  Symbology dropdown? Is it not supported under OS X?


* If I cycle through the all the UI preference choices in Preferenecs:
  Style (Windows, Motif, ..., Aqua), quitting-and-restarting each
  time, the result often is a seemingly corrupt QGIS setup that is
  more prone to crashing and confused behavior. I'm not sure exactly
  what goes wrong here, but this UI stuff seems...fragile.

  In order to reset preferences, it seems necessary to quit QGIS and

  rm -r ~/.qgis2
  defaults delete org.qgis.QGIS2
  defaults delete com.trolltech

  I'm not really sure what trigger is, or what the fix is, but it just
  seems...fragile. Also it would be helpful if that were documented. I
  guess the trolltech stuff is from Qt? Ugh.

% What's the right way to deal with crashes and backtraces? Do the
  QGIS developers want to see stack traces? Are there debugging
  symbols available? Or should I try to reproduce crashes in the
  current git checkout and analyze them myself?

* tried to open attribute table of layer after being idle for several hours

Application Specific Information:
*** Terminating app due to uncaught exception 'NSInvalidArgumentException', 
reason: '-[NSThemeFrame drawRectOriginal:]: unrecognized selector sent to 
instance 0x7fcfaf8baae0'
Performing @selector(qtDispatcherToQAction:) from sender NSMenuItem 
abort() called
terminating with uncaught exception of type NSException

Application Specific Backtrace 1:

* Crash dragging the label styling panel to the left (and resulting in
  corrupt preferences). Stack overflow, all 512 frames loook like this:

511 QtGui                               0x000000010a1c0e1e -[QCocoaWindow 
drawRectSpecial:] + 94

* In a corrupt preferences situation, sometimes QGIS half-hangs. Some
  parts of the UI are responsive, but pulldowns menus don't work. The
  menu bar flashes, but you can't pull anything down, Cmd-Q won't
  quit, etc.

* Some kind of threading/contention hang again? No CPU consumption,
  but no responsiveness. Undocked the Layer Styling panel  and moved
  it left, then tried to open the Attribute panel.
  There are menubar flashes, it behaves like there’s a model dialog
  offscreen or something (but there’s not?.

* Got this:
Application Specific Information:
*** Terminating app due to uncaught exception 'NSInvalidArgumentException', 
reason: '-[NSThemeFrame drawRectOriginal:]: unrecognized selector sent to 
instance 0x7fd9f8c594a0'
abort() called
terminating with uncaught exception of type NSException


And that's all, folks.
If you made it here, you get a special prize!

  John Hawkinson
Qgis-user mailing list
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user

Reply via email to