Hello,

I am trying to install QGIS 0.7.4 source on Suse Linux 10.1. I had NO
problems with compiling.

==========================================
qgis 0.7.4
------------------------------------------
GDAL/OGR      : yes (Version 1.3.2)
GEOS          : yes (Version 2.2.1)
PostgreSQL    : yes (Version 8.1.5)
GRASS         : yes
SPIT          : yes
Georeferencer : yes
GPS/GPX       : yes
PROJ4         : yes
SQLITE3       : yes

Debug         : no
Plugin dir    : ${exec_prefix}/lib/qgis

The binary will be installed in /usr/bin

The build is using Qt in /usr/local
Linking with -lqt-mt
------------------------------------------
Configure finished, type 'make' to build.



BUT, I get errors on make....



qgsproject.h:98: error: extra qualification 'QgsProject::' on member
'dirty'
qgsproject.h:100: error: extra qualification 'QgsProject::' on member
'dirty'
qgsrasterlayerproperties.h:72: error: extra qualification
'QgsRasterLayerProperties::' on member 'pbnHistRefresh_clicked'
qgsprojectproperties.h:63: error: extra qualification
'QgsProjectProperties::' on member 'isProjected'
gmake[4]: *** [libqgis_la-qgisapp.lo] Error 1
gmake[4]: Leaving directory `/usr/local/src/qgis-0.7.4/src'
gmake[3]: *** [all-recursive] Error 1
gmake[3]: Leaving directory `/usr/local/src/qgis-0.7.4/src'
gmake[2]: *** [all] Error 2
gmake[2]: Leaving directory `/usr/local/src/qgis-0.7.4/src'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/local/src/qgis-0.7.4'
gmake: *** [all] Error 2

I have searched the archives for information on the errors, and found
one listing that involved removing references to "error: extra
qualification 'QgsProject::' on member 'dirty'" on lines 98 and 100 of
qgsproject.h. Doing this, however, seemed to create just more errors. I
would appreciate any information on how I might proceed.

Thanks, Bill

_______________________________________________
Qgis-user mailing list
Qgis-user@lists.qgis.org
http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-user

Reply via email to