Hi!

I tried to compile the recent svn-version of qgis against qt-4.2.2,
resulting in the errors below. Afterwards I compiled without any
problems the svn-version from 2006-11-06 which I was running during the
last view weeks. Apparently a change made to the code during the last few
weeks causes the error ...

Cheers,

Henning

make[4]: Entering directory `/home/hl/sources/qgis/qgis-unstable/src/gui'
if /bin/bash ../../libtool --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H
-I. -I. -I../..    -DPREFIX=\"/usr\" -DPLUGINPATH=\"/usr/lib/qgis\"
-DPKGDATAPATH=\"/usr/share/qgis\" -I/usr/local/include -g -O2
-DQT3_SUPPORT -I/usr/local/Trolltech/Qt-4.2.2//mkspecs/default
-I/usr/local/Trolltech/Qt-4.2.2//include/Qt3Support
-I/usr/local/Trolltech/Qt-4.2.2//include/QtCore
-I/usr/local/Trolltech/Qt-4.2.2//include/QtDesigner
-I/usr/local/Trolltech/Qt-4.2.2//include/QtGui
-I/usr/local/Trolltech/Qt-4.2.2//include/QtNetwork
-I/usr/local/Trolltech/Qt-4.2.2//include/QtOpenGL
-I/usr/local/Trolltech/Qt-4.2.2//include/QtSql
-I/usr/local/Trolltech/Qt-4.2.2//include/QtXml
-I/usr/local/Trolltech/Qt-4.2.2//include
-I/usr/local/Trolltech/Qt-4.2.2//include/QtSvg
-I/usr/local/Trolltech/Qt-4.2.2//include/QtTest
-I/usr/local/Trolltech/Qt-4.2.2//include/QtDesigner -D_REENTRANT
-DQT_THREAD_SUPPORT -I/usr/include/postgresql -DNO_DEBUG
-I/usr/local/include -I/usr/include/python2.4  -I../ui/
-I../widgets/projectionselector/ -I../legend/ -I../raster/ -I../composer/
-I../core/ -I../plugins/ -g -O2 -MT libqgis_gui_la-qgsvectorlayer.lo -MD
-MP -MF ".deps/libqgis_gui_la-qgsvectorlayer.Tpo" -c -o
libqgis_gui_la-qgsvectorlayer.lo `test -f 'qgsvectorlayer.cpp' || echo
'./'`qgsvectorlayer.cpp; \
        then mv -f ".deps/libqgis_gui_la-qgsvectorlayer.Tpo"
        ".deps/libqgis_gui_la-qgsvectorlayer.Plo"; else rm -f
        ".deps/libqgis_gui_la-qgsvectorlayer.Tpo"; exit 1; fi
 g++ -DHAVE_CONFIG_H -I. -I. -I../.. -DPREFIX=\"/usr\"
 -DPLUGINPATH=\"/usr/lib/qgis\" -DPKGDATAPATH=\"/usr/share/qgis\"
 -I/usr/local/include -g -O2 -DQT3_SUPPORT
 -I/usr/local/Trolltech/Qt-4.2.2//mkspecs/default
 -I/usr/local/Trolltech/Qt-4.2.2//include/Qt3Support
 -I/usr/local/Trolltech/Qt-4.2.2//include/QtCore
 -I/usr/local/Trolltech/Qt-4.2.2//include/QtDesigner
 -I/usr/local/Trolltech/Qt-4.2.2//include/QtGui
 -I/usr/local/Trolltech/Qt-4.2.2//include/QtNetwork
 -I/usr/local/Trolltech/Qt-4.2.2//include/QtOpenGL
 -I/usr/local/Trolltech/Qt-4.2.2//include/QtSql
 -I/usr/local/Trolltech/Qt-4.2.2//include/QtXml
 -I/usr/local/Trolltech/Qt-4.2.2//include
 -I/usr/local/Trolltech/Qt-4.2.2//include/QtSvg
 -I/usr/local/Trolltech/Qt-4.2.2//include/QtTest
 -I/usr/local/Trolltech/Qt-4.2.2//include/QtDesigner -D_REENTRANT
 -DQT_THREAD_SUPPORT -I/usr/include/postgresql -DNO_DEBUG
 -I/usr/local/include -I/usr/include/python2.4 -I../ui/
 -I../widgets/projectionselector/ -I../legend/ -I../raster/ -I../composer/
 -I../core/ -I../plugins/ -g -O2 -MT libqgis_gui_la-qgsvectorlayer.lo -MD
 -MP -MF .deps/libqgis_gui_la-qgsvectorlayer.Tpo -c qgsvectorlayer.cpp
 -fPIC -DPIC -o .libs/libqgis_gui_la-qgsvectorlayer.o
qgsvectorlayer.cpp: In member function 'bool
QgsVectorLayer::setDataProvider(const QString&)': qgsvectorlayer.cpp:2270:
error: unknown escape sequence '\.' make[4]: ***
[libqgis_gui_la-qgsvectorlayer.lo] Error 1 make[4]: Leaving directory
`/home/hl/sources/qgis/qgis-unstable/src/gui' make[3]: *** [all] Error 2
make[3]: Leaving directory `/home/hl/sources/qgis/qgis-unstable/src/gui'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/hl/sources/qgis/qgis-unstable/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/hl/sources/qgis/qgis-unstable' make: ***
[all] Error 2
[EMAIL PROTECTED]:~/sources/qgis/qgis-unstable$ 



_______________________________________________
Qgis-user mailing list
Qgis-user@lists.qgis.org
http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-user

Reply via email to