Hy sergio,

I installed also the RPM depedencies form the same source. I didn't have the
georeferencer ok with configure. I tried so many way that maybe one left
something that helped me to go through finally.
I cannot really help you more (it was the very first time that I succeded a
compilation since I was born...)
I tried first to install the 62bits RPM but all the dependencies weren't
installable on 64bits (some 32bits libs had the same name than the 64bits
one).

So, "courage"

Jean

2007/2/17, Sergio López <[EMAIL PROTECTED]>:

Hi Jean,



I've followed your instructions and everything went well with ./configure,
receiving the output you can find below. But when  I make, I receive the
following error:


In file included from ../gui/qgscoordinatetransform.h:28,

                 from ../gui/qgsmaplayer.h:33,

                 from qgsdatamanager.cpp:19:

../gui/qgsspatialrefsys.h:20:21: error: ogr_api.h: No such file or
directory

../gui/qgsspatialrefsys.h:21:28: error: ogr_spatialref.h: No such file or
directory

../gui/qgsspatialrefsys.h:22:23: error: cpl_error.h: No such file or
directory

../gui/qgsspatialrefsys.h:207: error: 'OGRSpatialReference' does not name
a type

make[4]: *** [libqgis_core_la-qgsdatamanager.lo] Error 1




I have installed QGIS dependencies using RPMs. can that be the cause of
such error? should I use sources?

Sergio

./configure output:

==========================================

qgis 0.8.0

------------------------------------------

GDAL/OGR      : yes (Version 1.3.2)

GEOS          : yes (Version 2.2.3)

PostgreSQL    : yes (Version 8.1.3)

GRASS         : yes

SPIT          : yes

Georeferencer : yes

WFS           : yes

GPS/GPX       : yes

PROJ4         : yes

SQLITE3       : yes

Python        :



CPPFLAGS      :  -I/usr/include

CXXFLAGS      : -g -O2



Debug         : no

Plugin dir    : /usr/lib/qgis



The binary will be installed in /usr/bin



The build is using Qt in /usr/lib64/qt4

Linking with Qt using -lQtCore -lQt3Support -lQtGui -lQtNetwork -lQtSvg
-lQtCore -lQt3Support -lQtGui -lQtNetwork -lQtXml -lQtSvg -lQtTest
-lQtDesigner












----- Mensaje original ----

De: Jean Cayron <[EMAIL PROTECTED]>

Para: Sergio López <[EMAIL PROTECTED]>

CC: qgis-user@lists.qgis.org

Enviado: sábado 10 de febrero de 2007, 10:37:20

Asunto: Re: [Qgis-user] Problem compiling 0.8 on SUSE 10.2 64bits



Sorry,



I wasn't complete in my last post. I finally went through and I can now
use Qgis on openSuse 10. x86_64.

The way :



su

ln -s /usr/include /usr/lib64/qt4/include

ln -s /usr/bin /usr/lib64/qt4/bin

ls -s /usr/lib64 /usr/lib64/lib

exit



./configure --with-qtdir=/usr/lib64/qt4 --with-sqlite3dir=/usr
--with-grass=/usr/grass-6.2.1 --with-postgresql=/usr/bin --with-python



make

su

make install

cp /usr/lib/libqgis_gui.so.1 /usr/lib64/qt4/

exit



and it should work...



Jean









2007/2/10, Jean Cayron <[EMAIL PROTECTED] >:Hello,



I had the same problem.

I resolved the problem of lib lib64 moc etc. by doing this (as su) :



ln -s /usr/include /usr/lib64/qt4/include

ln -s /usr/bin /usr/lib64/qt4/bin

ls -s /usr/lib64 /usr/lib64/lib



Then I made make and make install. But I get other errors like these :

make[5]: Rien à faire pour « install-exec-am ».

make[5]: Rien à faire pour « install-data-am ».



When I tried the commande qgis it said :

> qgis

qgis: error while loading shared libraries: libqgis_gui.so.1: cannot open
shared object file: No such file or directory



If you manage to make a rpm or have a good method, please, inform us...
It's days I'm trying.



Jean







2007/2/9, Sergio López <[EMAIL PROTECTED] >: I'm trying to compile
qgis 0.8 from source with grass support on a SUSE 10.2 64bits box, but I
bumped into a problem with the QT4 libraries.







I can't find a solution to the with-qtdir parameter, because my libraries
are located in /usr/lib64/qt4 but there's no "include" directory there.



I found a solution in here
http://www.nabble.com/Problems-compiling-qgis-0.8.0-tf3083766.html#a8599051









but when I ./configure I receive the following error:



checking QTDIR... /usr/lib64/qt4

checking Qt version in /usr/lib64/qt4/include/Qt... 421 (4)

checking for moc... no

configure: error: *** moc must be in path



by the way moc is located in /usr/bin, which IS already in path :



echo $PATH

/home/sergio/bin:/usr/local/bin:/usr/bin:/usr/X11R6/bin..etc



Can anyone tell me how to solve this issue please?

Thanks in advance.



Sergio























__________________________________________________

Preguntá. Respondé. Descubrí.

Todo lo que querías saber, y lo que ni imaginabas,

está en Yahoo! Respuestas (Beta).

¡Probalo ya!

  http://www.yahoo.com.ar/respuestas



_______________________________________________

Qgis-user mailing list

Qgis-user@lists.qgis.org

http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-user

























__________________________________________________
Preguntá. Respondé. Descubrí.
Todo lo que querías saber, y lo que ni imaginabas,
está en Yahoo! Respuestas (Beta).
¡Probalo ya!
http://www.yahoo.com.ar/respuestas


_______________________________________________
Qgis-user mailing list
Qgis-user@lists.qgis.org
http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-user

Reply via email to