Hi Andrea

I tried the following:

- formatted a 400MB qxl.win drive with QPC and
- tried to copy a 200MiB file onto it (from a "dos" device). I got an
end of file error, too, but parts of the file (about 33MiB) were copied.

I then used SMSQmulator with the same drive (not reformatted), deleted
the part file and copied the same 200 MiB file onto it. This took a VERY
long time, but it worked.

Going then back to QPC, I checked the drive with drvlink and drvchk,
everything was OK. I then renamed the file just copied and, still under
QPC, copied it back to the "dos" disk.

This worked OK. I compared both files, the original that had been copied
to the qxl.win drive and the one copied back from it - they were identical.

So, the formatting under QPC was OK, but the copying from DOS drive to
qxl.win was not. This could be a problem with the dos device or with the
win devie. From your comments (trying to copy a large file from RAM) I
gather that it is rather the win device.

The problem here is that for win drives, QPC uses the standard SMSQ/E
level 3 driver, whereas SMSQmulator uses a driver entirely written in Java.

I can also switch SMSQmulator to use the SMSQ/E drivers. I'll do that
some time in august and try to see whether the problem also arises there
with that driver. If so, perhaps I could fix it.

QL-Users Mailing List

Reply via email to