Hi Daniel,

I had a similar problem regarding a large menu in EP4. I originally wrote it without any problems but when I came to load it again to make some slight changes I found that it wouldn't load. A member from the local Sub Group was also playing about with it and he found that it would load OK if he changed the screen resolution. (or was it the MODE?). Whichever it was worked for metoo! As you say, it worked when running the complete programme, so I didn't try to do anything else with it. (I may have got an error report when trying to load it outside the main programme (saying something to the effect that it was too large for the space available!) but it was a long time ago and we are all getting older!!


HTH

Kind Regards,

John Gilpin.





On 27/08/2017 21:40, Daniel Baum via Ql-Users wrote:
Hi all,

Almost 20 years ago I wrote a program called Qbase, and now I am trying to
run and compile the source code.

There are two versions, the older one is mostly text based, with a few
added menus. This version runs and compiles without any problems.

The newer version was written with easyPtr, and I am having problems
getting some of the menu files to work. Most of the menus load and display
without any problems but the main menus do not. I can load them into
easyMenu, but MDRAW does not display them, the menus either do not display
at all, or they are garbled.

The main menus are much larger than the sub menus (the ones that do work),
so maybe that's a clue.

The actual compiled program from the zip does work, and I am stumped.

Obviously both the operating system and easyPtr have gone through many
versions since I wrote qbase, so I assume something has changed in the
environment. Does anyone have a clue where I should look? I am using the
latest QPC, SMSQ/E and easyPtr, as far as I know.

Thanks,

D.
_______________________________________________
QL-Users Mailing List


_______________________________________________
QL-Users Mailing List

Reply via email to